xref: /xv6-public/runoff.spec (revision 0aef8914)
1# types.h either
2# param.h either
3# defs.h either
4# x86.h either
5# asm.h either
6# mmu.h either
7# elf.h either
8# mp.h either
9
10even: bootasm.S  # mild preference
11even: bootother.S  # mild preference
12# bootmain.c either
13even: main.c
14# mp.c don't care at all
15# even: initcode.S
16# odd: init.c
17
18# spinlock.h either
19# spinlock.c either
20even: proc.h  # mild preference
21
22# goal is to have two action-packed 2-page spreads,
23# one with
24#     ksegment usegment allocproc userinit growproc fork
25# and another with
26#     scheduler sched yield forkret sleep wakeup1 wakeup
27right: proc.c   # VERY important
28
29# setjmp.S either
30# kalloc.c either
31
32# syscall.h either
33# trapasm.S either
34# traps.h either
35# even: trap.c
36# vectors.pl either
37# syscall.c either
38# sysproc.c either
39
40# buf.h either
41# dev.h either
42# fcntl.h either
43# stat.h either
44# file.h either
45# fs.h either
46# fsvar.h either
47left: ide.c
48# odd: bio.c
49odd: fs.c   # VERY important
50# file.c either
51# exec.c either
52# sysfile.c either
53
54# even: pipe.c  # mild preference
55# string.c either
56left: kbd.h
57even: console.c
58odd: sh.c
59