xref: /xv6-public/runoff.spec (revision 87b2099a)
1# types.h either
2# param.h either
3# defs.h either
4# x86.h either
5# asm.h either
6# mmu.h either
7# elf.h either
8# mp.h either
9
10even: bootasm.S  # mild preference
11even: bootother.S  # mild preference
12# bootmain.c either
13even: main.c
14# mp.c don't care at all
15# even: initcode.S
16# odd: init.c
17
18# spinlock.h either
19right: spinlock.c  # mild preference
20even: proc.h  # mild preference
21
22# goal is to have two action-packed 2-page spreads,
23# one with
24#     allocproc userinit growproc fork
25# and another with
26#     scheduler sched yield forkret sleep wakeup1 wakeup
27right+: proc.c   # VERY important
28
29# setjmp.S either
30# vm.c either
31# kalloc.c either
32
33# syscall.h either
34# trapasm.S either
35# traps.h either
36# even: trap.c
37# vectors.pl either
38# syscall.c either
39# sysproc.c either
40
41# buf.h either
42# dev.h either
43# fcntl.h either
44# stat.h either
45# file.h either
46# fs.h either
47# fsvar.h either
48left: ide.c
49# odd: bio.c
50odd: fs.c   # VERY important
51# file.c either
52# exec.c either
53# sysfile.c either
54
55# even: pipe.c  # mild preference
56# string.c either
57left: kbd.h
58even: console.c
59odd: sh.c
60