xref: /xv6-public/runoff.spec (revision d2c7f649)
1sheet1: left
2
3# "left" and "right" specify which page of a two-page spread a file
4# must start on.  "left" means that a file must start on the first of
5# the two page.  "right" means it must start on the second of the two
6# pages.  The file may start in either column.
7#
8# "even" and "odd" specify which column a file must start on.  "even"
9# means it must start in the left of the two columns.  "odd" means it
10# must start in the right of the two columns.
11
12# types.h either
13# param.h either
14# defs.h either
15# x86.h either
16# asm.h either
17# mmu.h either
18# elf.h either
19# mp.h either
20
21even: bootasm.S  # mild preference
22even: bootother.S  # mild preference
23# bootmain.c either
24even: main.c
25# mp.c don't care at all
26# even: initcode.S
27# odd: init.c
28
29# spinlock.h either
30left: spinlock.c  # mild preference
31even: proc.h  # mild preference
32
33# goal is to have two action-packed 2-page spreads,
34# one with
35#     allocproc userinit growproc fork
36# and another with
37#     scheduler sched yield forkret sleep wakeup1 wakeup
38right: proc.c   # VERY important
39
40# setjmp.S either
41# vm.c either
42# kalloc.c either
43
44# syscall.h either
45# trapasm.S either
46# traps.h either
47# even: trap.c
48# vectors.pl either
49# syscall.c either
50# sysproc.c either
51
52# buf.h either
53# dev.h either
54# fcntl.h either
55# stat.h either
56# file.h either
57# fs.h either
58# fsvar.h either
59left: ide.c
60# odd: bio.c
61odd: fs.c   # VERY important
62# file.c either
63# exec.c either
64# sysfile.c either
65
66# even: pipe.c  # mild preference
67# string.c either
68left: kbd.h
69even: console.c
70odd: sh.c
71