xref: /xv6-public/runoff.spec (revision eaea18cb)
1# types.h either
2# param.h either
3# defs.h either
4# x86.h either
5# asm.h either
6# mmu.h either
7# elf.h either
8# mp.h either
9
10even: bootasm.S  # mild preference
11even: bootother.S  # mild preference
12# bootmain.c either
13even: main.c
14# mp.c don't care at all
15even: initcode.S
16odd: init.c
17
18# spinlock.h either
19# spinlock.c either
20even: proc.h  # mild preference
21even: proc.c  # VERY important
22# setjmp.S either
23# kalloc.c either
24
25# syscall.h either
26# trapasm.S either
27# traps.h either
28even: trap.c  # important
29# vectors.pl either
30# syscall.c either
31# sysproc.c either
32
33# buf.h either
34# dev.h either
35# fcntl.h either
36# stat.h either
37# file.h either
38# fs.h either
39# fsvar.h either
40# even: ide.c
41# odd: bio.c
42odd: fs.c   # VERY important
43# file.c either
44# exec.c either
45# sysfile.c either
46
47even: pipe.c  # mild preference
48# string.c either
49# even: console.c
50
51