History log of /netbsd/sys/sys/bufq_impl.h (Results 1 – 10 of 10)
Revision Date Author Comments
# c7e8ffaf 16-Nov-2016 pgoyette <pgoyette@NetBSD.org>

Modularize the various bufq strategies


# 3f58b6fc 02-Nov-2011 yamt <yamt@NetBSD.org>

buf_inorder:
- make the return value bool
- comments


# 3e196b68 19-Jan-2009 yamt <yamt@NetBSD.org>

malloc -> kmem_alloc


# 5fc434dc 30-Apr-2008 reinoud <reinoud@NetBSD.org>

Add a BUFQ_CANCEL() next to BUFQ_PUT() and BUFQ_GET().

BUFQ_CANCEL(queue, element) removes the specified element previously queued
on the queue. It returns NULL if it was not found on the queue and

Add a BUFQ_CANCEL() next to BUFQ_PUT() and BUFQ_GET().

BUFQ_CANCEL(queue, element) removes the specified element previously queued
on the queue. It returns NULL if it was not found on the queue and the
element if it was successfully removed.

Run trough tech-kern and changed name from BUFQ_REVOKE() by suggestion of
Jason Thorpe.

show more ...


# ce099b40 28-Apr-2008 martin <martin@NetBSD.org>

Remove clause 3 and 4 from TNF licenses


# fbae48b9 16-Feb-2006 perry <perry@NetBSD.org>

Change "inline" back to "__inline" in .h files -- C99 is still too
new, and some apps compile things in C89 mode. C89 keywords stay.

As per core@.


# e14523e9 24-Dec-2005 perry <perry@NetBSD.org>

Remove leading __ from __(const|inline|signed|volatile) -- it is obsolete.


# 95e1ffb1 11-Dec-2005 christos <christos@NetBSD.org>

merge ktrace-lwp.


# 9f4759cc 16-Oct-2005 yamt <yamt@NetBSD.org>

add some bufq helper functions.
#if 0'ed out as there is no user currently.


# aec75b1c 15-Oct-2005 yamt <yamt@NetBSD.org>

- change the way to specify a bufq strategy. (by string rather than by number)
- rather than embedding bufq_state in driver softc,
have a pointer to the former.
- move bufq related functions from

- change the way to specify a bufq strategy. (by string rather than by number)
- rather than embedding bufq_state in driver softc,
have a pointer to the former.
- move bufq related functions from kern/subr_disk.c to kern/subr_bufq.c.
- rename method to strategy for consistency.
- move some definitions which don't need to be exposed to the rest of kernel
from sys/bufq.h to sys/bufq_impl.h.
(is it better to move it to kern/ or somewhere?)
- fix some obvious breakage in dev/qbus/ts.c. (not tested)

show more ...