History log of /openbsd/sys/dev/ata/atascsi.c (Results 1 – 25 of 154)
Revision Date Author Comments
# 0f9e9ec2 13-May-2024 jsg <jsg@openbsd.org>

remove prototypes with no matching function
ok mpi@


# a454aff3 16-Apr-2022 naddy <naddy@openbsd.org>

constify SCSI adapter entry points

ok krw@


# 51d3b00d 09-Apr-2022 naddy <naddy@openbsd.org>

atascsi: constify method tables

ok miod@


# 4b1a56af 09-Jan-2022 jsg <jsg@openbsd.org>

spelling
feedback and ok tb@ jmc@ ok ratchov@


# a83ec286 15-Oct-2020 krw <krw@openbsd.org>

Replace simple one-line bcopy()/memcpy() of faked data into scsi_xfer with call
to scsi_copy_internal_data(). Thus getting xs->resid properly set and adding the
usual uio/size sanity checks.


# 664c6166 22-Sep-2020 krw <krw@openbsd.org>

Since dlg@'s 2009 scsi midlayer refactoring the 'struct scsi_generic *cmd'
member of 'struct scsi_xfer' has always been pointed at the 'struct scsi_generic
cmdstore' member of the same instance. So n

Since dlg@'s 2009 scsi midlayer refactoring the 'struct scsi_generic *cmd'
member of 'struct scsi_xfer' has always been pointed at the 'struct scsi_generic
cmdstore' member of the same instance. So nuke 'cmdstore' and remove the '*'
from cmd. Take the address of cmd as required by the various casts.

No intentional functional change.

luna88k test by aoyama@, sparc64 test by jmatthew@

Identification of 2009's last *cmd use and ok jmatthew@

show more ...


# 3ca8dabf 05-Sep-2020 krw <krw@openbsd.org>

Replace '32' with SID_SCSI2_ALEN (a.k.a. 31) when building emulated INQUIRY
responses. This is what the SCSI specifications say is the correct value and
already used in several cases.


# bb4b71eb 03-Sep-2020 krw <krw@openbsd.org>

Replace '.response_format = 2' with '.response_format = SID_SCSI2_RESPONSE'.


# b291b595 02-Sep-2020 krw <krw@openbsd.org>

When building emulated INQUIRY results use the SCSI_REV_* #define's to
initialize the 'version' field. Not numbers.


# eccd596d 01-Sep-2020 krw <krw@openbsd.org>

Rename [READ|WRITE]_BIG to [READ|WRITE]_10. Rename struct scsi_rw_big to
struct scsi_rw_10.

ok gnezdo@ jmatthew@ (who also did sparc64 compile test)


# fc548c49 26-Aug-2020 krw <krw@openbsd.org>

Remove needless uses of SDEV_ONLYBIG. It was always set when SDEV_UMASS was set,
and was always checked in concert with SDEV_ATAPI. Just rely on SDEV_ATAPI and
SDEV_UMASS in all but the one place sd(

Remove needless uses of SDEV_ONLYBIG. It was always set when SDEV_UMASS was set,
and was always checked in concert with SDEV_ATAPI. Just rely on SDEV_ATAPI and
SDEV_UMASS in all but the one place sd(4) where SDEV_ONLYBIG is set
independently of SDEV_ATAPI/_UMASS.

ok jmatthew@

show more ...


# 7380a3a4 22-Jul-2020 krw <krw@openbsd.org>

Nuke unused struct scsi_link members of adapter softc's where the
driver successfully compiles on one or more of amd64, i386, hppa.


# e5eae15d 20-Jul-2020 krw <krw@openbsd.org>

Move remaining scsi bus initialization info from "prototype scsi link"
fields to struct scsibus_attach_args. Nuke the struct scsi_link *
(saa_sc_link) in scaibus_attach_args.

Explicitly initialize e

Move remaining scsi bus initialization info from "prototype scsi link"
fields to struct scsibus_attach_args. Nuke the struct scsi_link *
(saa_sc_link) in scaibus_attach_args.

Explicitly initialize each field in scsibus_attach_args variables.

show more ...


# ead808c4 19-Jul-2020 krw <krw@openbsd.org>

Move the adapter related items (luns, adapter, adapter_target,
adapter_buswidth, adapter_softc) from struct scsi_link to struct
scsibus_attach_args.

Additional compile tests by jmatthew@ (sparc64) a

Move the adapter related items (luns, adapter, adapter_target,
adapter_buswidth, adapter_softc) from struct scsi_link to struct
scsibus_attach_args.

Additional compile tests by jmatthew@ (sparc64) and aoyam@ (luna88k).

show more ...


# 499fa1f2 17-Jul-2020 krw <krw@openbsd.org>

Always a joker hiding somewhere.

Access adapter_buswidth via link->bus->sb_adapter_buswidth.


# 0b29cb40 16-Jul-2020 krw <krw@openbsd.org>

Access adapter softc via link->bus->sb_adapter_softc.

In sparc64 autoconf access 'luns' via sb_luns and 'adapter_buswidth'
via sb_adapter_buswidth.

Removes last post-config uses of the copies of bu

Access adapter softc via link->bus->sb_adapter_softc.

In sparc64 autoconf access 'luns' via sb_luns and 'adapter_buswidth'
via sb_adapter_buswidth.

Removes last post-config uses of the copies of bus related
information in scsi_link.

show more ...


# e803e20a 11-Jul-2020 krw <krw@openbsd.org>

Expunge some Captain Obvious comments, tweak whitespace a bit, move a debug
statement. All to make upcoming diff(s) smaller and easier to read.


# 3ba66839 02-Jul-2020 krw <krw@openbsd.org>

Shuffle things around so that sc->sc_link initialization is
even more concentrated just before config_found().


# 382c0517 27-Jun-2020 krw <krw@openbsd.org>

Nuke trailing whitespace.


# a7997e14 27-Jun-2020 krw <krw@openbsd.org>

No need to bzero()/memset() 'struct scsibus_attach_args' variables
immediately before initializing the only field in the struct.


# 182e13b7 24-Jun-2020 krw <krw@openbsd.org>

Use SDEV_NO_ADAPTER_TARGET instead of the value that is being
aassigned to adapter_buswidth to indicate the adapter is not a target
on the bus.

ok dlg@ as part of a larger diff.


# 21ceeee0 05-Feb-2020 krw <krw@openbsd.org>

Nuke unnecessary abstraction 'scsi_minphys()' which just calls
'minphys()'. Just use & check for NULL instead, since 'minphys()' is
always called on the code path ([cd|sd|st]minphys) that calls
physi

Nuke unnecessary abstraction 'scsi_minphys()' which just calls
'minphys()'. Just use & check for NULL instead, since 'minphys()' is
always called on the code path ([cd|sd|st]minphys) that calls
physio().

show more ...


# 9f36bc94 26-Jan-2020 krw <krw@openbsd.org>

Shuffle some names around to make reading the code less headache
inducing. Rename scsi_adapter member 'scsi_minphys' to 'dev_minphys'
to reflect what it is supposed to do. Use consistent naming conve

Shuffle some names around to make reading the code less headache
inducing. Rename scsi_adapter member 'scsi_minphys' to 'dev_minphys'
to reflect what it is supposed to do. Use consistent naming convention
(<dev>_minphys) for the actual device functions.

No functional change.

show more ...


# a867c811 23-Jan-2020 krw <krw@openbsd.org>

Use a consistant idiom/format when declaring scsi_adapter structures
in drivers. Terse one liners, NULLs instead of 0's, explicitly specify
all members, etc.

Nuke #ifdef notyet blocks related to the

Use a consistant idiom/format when declaring scsi_adapter structures
in drivers. Terse one liners, NULLs instead of 0's, explicitly specify
all members, etc.

Nuke #ifdef notyet blocks related to the scsi_adapter in aic.

No intentional functional change.

ok tedu@

show more ...


# cf065217 19-Aug-2019 krw <krw@openbsd.org>

Remove some unused code left over from an ancient (i.e. 2007) attempt
to present wd disks as sd drives.

ok deraadt@


1234567