#
36a1ca01 |
| 10-Apr-2024 |
David Arinzon <darinzon@amazon.com> |
net: ena: Set tx_info->xdpf value to NULL
The patch mentioned in the `Fixes` tag removed the explicit assignment of tx_info->xdpf to NULL with the justification that there's no need to set tx_info->
net: ena: Set tx_info->xdpf value to NULL
The patch mentioned in the `Fixes` tag removed the explicit assignment of tx_info->xdpf to NULL with the justification that there's no need to set tx_info->xdpf to NULL and tx_info->num_of_bufs to 0 in case of a mapping error. Both values won't be used once the mapping function returns an error, and their values would be overridden by the next transmitted packet.
While both values do indeed get overridden in the next transmission call, the value of tx_info->xdpf is also used to check whether a TX descriptor's transmission has been completed (i.e. a completion for it was polled).
An example scenario: 1. Mapping failed, tx_info->xdpf wasn't set to NULL 2. A VF reset occurred leading to IO resource destruction and a call to ena_free_tx_bufs() function 3. Although the descriptor whose mapping failed was freed by the transmission function, it still passes the check if (!tx_info->skb)
(skb and xdp_frame are in a union) 4. The xdp_frame associated with the descriptor is freed twice
This patch returns the assignment of NULL to tx_info->xdpf to make the cleaning function knows that the descriptor is already freed.
Fixes: 504fd6a5390c ("net: ena: fix DMA mapping function issues in XDP") Signed-off-by: Shay Agroskin <shayagr@amazon.com> Signed-off-by: David Arinzon <darinzon@amazon.com> Reviewed-by: Shannon Nelson <shannon.nelson@amd.com> Signed-off-by: Paolo Abeni <pabeni@redhat.com>
show more ...
|
#
06a96fe6 |
| 30-Jan-2024 |
David Arinzon <darinzon@amazon.com> |
net: ena: Remove CQ tail pointer update
The functionality was added to allow the drivers to create an SQ and CQ of different sizes. When the RX/TX SQ and CQ have the same size, such update isn't nec
net: ena: Remove CQ tail pointer update
The functionality was added to allow the drivers to create an SQ and CQ of different sizes. When the RX/TX SQ and CQ have the same size, such update isn't necessary as the device can safely assume it doesn't override unprocessed completions. However, if the SQ is larger than the CQ, the device might "have" more completions it wants to update about than there's room in the CQ.
There's no support for different SQ and CQ sizes, therefore, removing the API and its usage.
'____cacheline_aligned' compiler attribute was added to 'struct ena_com_io_cq' to ensure that the removal of the 'cq_head_db_reg' field doesn't change the cache-line layout of this struct.
Signed-off-by: Shay Agroskin <shayagr@amazon.com> Signed-off-by: David Arinzon <darinzon@amazon.com> Signed-off-by: Paolo Abeni <pabeni@redhat.com>
show more ...
|
#
ea5c4600 |
| 01-Jan-2024 |
David Arinzon <darinzon@amazon.com> |
net: ena: Always register RX queue info
The RX queue info contains information about the RX queue which might be relevant to the kernel.
To avoid configuring this queue for different scenarios, thi
net: ena: Always register RX queue info
The RX queue info contains information about the RX queue which might be relevant to the kernel.
To avoid configuring this queue for different scenarios, this patch moves the RX queue configuration to ena_up()/ena_down() function and makes it configured every interface state toggle.
Signed-off-by: Shay Agroskin <shayagr@amazon.com> Signed-off-by: David Arinzon <darinzon@amazon.com> Link: https://lore.kernel.org/r/20240101190855.18739-10-darinzon@amazon.com Signed-off-by: Jakub Kicinski <kuba@kernel.org>
show more ...
|
#
2b02e332 |
| 01-Jan-2024 |
David Arinzon <darinzon@amazon.com> |
net: ena: Add more debug prints to XDP related function
Used for better readability and debugging of XDP flow.
Signed-off-by: Shay Agroskin <shayagr@amazon.com> Signed-off-by: David Arinzon <darinz
net: ena: Add more debug prints to XDP related function
Used for better readability and debugging of XDP flow.
Signed-off-by: Shay Agroskin <shayagr@amazon.com> Signed-off-by: David Arinzon <darinzon@amazon.com> Link: https://lore.kernel.org/r/20240101190855.18739-9-darinzon@amazon.com Signed-off-by: Jakub Kicinski <kuba@kernel.org>
show more ...
|
#
b626fd96 |
| 01-Jan-2024 |
David Arinzon <darinzon@amazon.com> |
net: ena: Refactor napi functions
This patch focuses on changes to the XDP part of the napi polling routine.
1. Update the `napi_comp` stat only when napi is actually complete. 2. Simplify the c
net: ena: Refactor napi functions
This patch focuses on changes to the XDP part of the napi polling routine.
1. Update the `napi_comp` stat only when napi is actually complete. 2. Simplify the code by using a function pointer to the right napi routine (XDP vs non-XDP path) 3. Remove unnecessary local variables. 4. Adjust a debug print to show the processed XDP frame index rather than the pointer.
Signed-off-by: David Arinzon <darinzon@amazon.com> Link: https://lore.kernel.org/r/20240101190855.18739-8-darinzon@amazon.com Signed-off-by: Jakub Kicinski <kuba@kernel.org>
show more ...
|
#
911a8c96 |
| 01-Jan-2024 |
David Arinzon <darinzon@amazon.com> |
net: ena: Use tx_ring instead of xdp_ring for XDP channel TX
When an XDP program is loaded the existing channels in the driver split into two halves: - The first half of the channels contain RX and
net: ena: Use tx_ring instead of xdp_ring for XDP channel TX
When an XDP program is loaded the existing channels in the driver split into two halves: - The first half of the channels contain RX and TX rings, these queues are used for receiving traffic and sending packets originating from kernel. - The second half of the channels contain only a TX ring. These queues are used for sending packets that were redirected using XDP_TX or XDP_REDIRECT.
Referring to the queues in the second half of the channels as "xdp_ring" can be confusing and may give the impression that ENA has the capability to generate an additional special queue.
This patch ensures that the xdp_ring field is exclusively used to describe the XDP TX queue that a specific RX queue needs to utilize when forwarding packets with XDP TX and XDP REDIRECT, preserving the integrity of the xdp_ring field in ena_ring.
Signed-off-by: Shay Agroskin <shayagr@amazon.com> Signed-off-by: David Arinzon <darinzon@amazon.com> Link: https://lore.kernel.org/r/20240101190855.18739-6-darinzon@amazon.com Signed-off-by: Jakub Kicinski <kuba@kernel.org>
show more ...
|
#
39a044f4 |
| 01-Jan-2024 |
David Arinzon <darinzon@amazon.com> |
net: ena: Pass ena_adapter instead of net_device to ena_xmit_common()
This change will enable the ability to use ena_xmit_common() in functions that don't have a net_device pointer. While it can be
net: ena: Pass ena_adapter instead of net_device to ena_xmit_common()
This change will enable the ability to use ena_xmit_common() in functions that don't have a net_device pointer. While it can be retrieved by dereferencing ena_adapter (adapter->netdev), there's no reason to do it in fast path code where this pointer is only needed for debug prints.
Signed-off-by: Shay Agroskin <shayagr@amazon.com> Signed-off-by: David Arinzon <darinzon@amazon.com> Link: https://lore.kernel.org/r/20240101190855.18739-3-darinzon@amazon.com Signed-off-by: Jakub Kicinski <kuba@kernel.org>
show more ...
|
#
d000574d |
| 01-Jan-2024 |
David Arinzon <darinzon@amazon.com> |
net: ena: Move XDP code to its new files
XDP system has a very large footprint in the driver's overall code. makes the whole driver's code much harder to read.
Moving XDP code to dedicated files.
net: ena: Move XDP code to its new files
XDP system has a very large footprint in the driver's overall code. makes the whole driver's code much harder to read.
Moving XDP code to dedicated files.
This patch doesn't make any changes to the code itself and only cut-pastes the code into ena_xdp.c and ena_xdp.h files so the change is purely cosmetic.
Signed-off-by: Shay Agroskin <shayagr@amazon.com> Signed-off-by: David Arinzon <darinzon@amazon.com> Link: https://lore.kernel.org/r/20240101190855.18739-2-darinzon@amazon.com Signed-off-by: Jakub Kicinski <kuba@kernel.org>
show more ...
|