History log of /openbsd/usr.bin/make/dir.c (Results 1 – 25 of 69)
Revision Date Author Comments
# c9fc29cf 04-Sep-2023 espie <espie@openbsd.org>

GC old code that was originally implemented to facilitate adoption by
other BSDs, which never happened, so make things simpler for further
development.

Ditches config.h entirely since it gets reduce

GC old code that was originally implemented to facilitate adoption by
other BSDs, which never happened, so make things simpler for further
development.

Ditches config.h entirely since it gets reduced to 2 defines.

okay tb@

show more ...


# 568f6c05 21-Oct-2016 espie <espie@openbsd.org>

small obvious cleanups:
- remove a lot of unnecessary casts
- zap extra param that's no longer needed
- add proper prototype and make function static

okay natano@


# 6eef43d0 23-Jan-2015 espie <espie@openbsd.org>

a wee little bit more cleanup (more const and remove noise from CDIAGFLAGS...
-pedantic kind of requires -std=c99 here to avoid LL warnings)
okay miod@, millert@


# 7f5855dc 23-Jan-2015 espie <espie@openbsd.org>

remove a bunch of dangerous casts (useless casts from void * to something
else, in some cases by adding extra temporary variables.
IMO, it's much better practice to do

void *a;
int *p = a;
*p = 42;

remove a bunch of dangerous casts (useless casts from void * to something
else, in some cases by adding extra temporary variables.
IMO, it's much better practice to do

void *a;
int *p = a;
*p = 42;

rather than
void *a;
*(int *)a = 42;

okay miod@... to be revisited for some possible const additions later.

show more ...


# 452f2662 16-Jan-2015 deraadt <deraadt@openbsd.org>

switch to <limits.h>; ok millert


# e2ff9f51 12-May-2014 espie <espie@openbsd.org>

adjust to ohash being in libutil now, and to the interface changes.
fix potential integer overflows in memory allocation (mostly for pedagogical
purposes, these are unlikely to overflow in practice)

adjust to ohash being in libutil now, and to the interface changes.
fix potential integer overflows in memory allocation (mostly for pedagogical
purposes, these are unlikely to overflow in practice)
move the rest of lst.lib stuff into its own directory.

show more ...


# 4c9de429 22-May-2013 espie <espie@openbsd.org>

as checked through thorough tests, youngest->mtime == ctime, so ditch
the extra field.

remove some extra abstraction layer: use clock_gettime directly
instead of ts_set_from_now (what is "now" anywa

as checked through thorough tests, youngest->mtime == ctime, so ditch
the extra field.

remove some extra abstraction layer: use clock_gettime directly
instead of ts_set_from_now (what is "now" anyways)

time_to_string takes param by pointer

rename "now" into starttime (more accurate term)

randomize queue uses arc4random_uniform (prompted by deraadt@)

display debug timestamp with ns too (it's debug, so it doesn't really
matter whichever way it's done, as long as it's done)

okay millert@

show more ...


# 1f89b472 23-Apr-2013 espie <espie@openbsd.org>

remove TIMESTAMP abstraction layer, prodded by theo.
while there, clean up includes.
use strtoll for ar timestamps (pretty much unused in reality, more
standard conforming than anything)

use idea fr

remove TIMESTAMP abstraction layer, prodded by theo.
while there, clean up includes.
use strtoll for ar timestamps (pretty much unused in reality, more
standard conforming than anything)

use idea from Todd to adapt to time_t being 32 bits OR 64 bits
(pedantically correct: INT_MIN would work just fine up to 1910 or so...)

okay millert@, gone thru a make build.

show more ...


# 27f372e2 07-Dec-2012 espie <espie@openbsd.org>

gc dead code


# 1bae8e1f 02-Oct-2012 espie <espie@openbsd.org>

more changes, discussed and tested by various people.
- put back some job control, turns out it's necessary when we don't run a
shell.
- zap old #ifdef CLEANUP code... probably doesn't even compile.

more changes, discussed and tested by various people.
- put back some job control, turns out it's necessary when we don't run a
shell.
- zap old #ifdef CLEANUP code... probably doesn't even compile.
- kill most of the OP_LIB code. Just keep a wee little bit for compatibility
(deprecated .LIBS and .INCLUDES, warns for weird dependencies instead of
erroring out).
- much improved debugging and -p output: sort variables, targets, rules,
output stuff in a nicer format mimicing input.
- better error message when no command is found, explain where the target comes from.
- sort final error list by file.
- show system files in errors as <bsd.prog.mk>
- reincorporate random delay, that was dropped
- optimize siginfo output by not regenerating the whole string each time.
- finish zapping old LocationInfo field that's no longer used.

show more ...


# bb4544df 19-Jul-2010 espie <espie@openbsd.org>

Correct $OpenBSD$ stuff


# dba68890 19-Jul-2010 espie <espie@openbsd.org>

two small changes:
- allow variables in SysV modifiers, as requested by matthieu@
(since recursive variables are an extension, this just extends the
extension)
- variation on :Q called :QL (quote li

two small changes:
- allow variables in SysV modifiers, as requested by matthieu@
(since recursive variables are an extension, this just extends the
extension)
- variation on :Q called :QL (quote list), which does quote every character
EXCEPT for whitespace. e.g.,

toto:
@for i in ${VAR:QL} ...

show more ...


# ce3d097d 16-Aug-2009 espie <espie@openbsd.org>

modify timestamp handling to grab current time instead of relying on a
stale timestamp.

all those diffs sent to people ages ago, who didn't answer, except for
Theo, who said he ran it with no issues

modify timestamp handling to grab current time instead of relying on a
stale timestamp.

all those diffs sent to people ages ago, who didn't answer, except for
Theo, who said he ran it with no issues, so let's get this in...

show more ...


# 6c2dbbda 04-Nov-2008 espie <espie@openbsd.org>

changes to get target equivalence to work better.
- add new file to create lists of equivalent targets (siblings)
- use that for sequential mode to have much better VPATH support
- separate checking

changes to get target equivalence to work better.
- add new file to create lists of equivalent targets (siblings)
- use that for sequential mode to have much better VPATH support
- separate checking commands from reporting error, for later.
- zap DieHorribly accordingly
- renumber existing flags
- signal_running_jobs() is simpler than pass_signal_to_jobs()
- new debug option -dn for name matching.

Similar code to handle parallel make is still missing.

thanks to Mark, Miod, Theo, Otto, Todd for tests and/or comments.

show more ...


# eb653e67 17-Sep-2007 espie <espie@openbsd.org>

reorg the directory code a bit.

Instead of readDir, explicitly create PathEntry, and increment the refcount
in there, which is simpler.


# 87d70e8b 17-Sep-2007 espie <espie@openbsd.org>

better variable name


# cbd06537 17-Sep-2007 espie <espie@openbsd.org>

kill extra spaces at end of line


# 07e620d4 16-Sep-2007 espie <espie@openbsd.org>

remove old debug code nothing uses


# 2a514a5a 16-Sep-2007 espie <espie@openbsd.org>

rename dirSearchPath -> defaultPath, and openDirectories -> knownDirectories


# ce889962 16-Sep-2007 espie <espie@openbsd.org>

rename Path to less misleading PathEntry. Get rid of typedef.


# 642cb917 16-Sep-2007 espie <espie@openbsd.org>

rename Targ_FmtTime into time_to_string and move it, as it's not related
to target nodes at all (reduces modules inter-dependencies)


# ff4f28c0 16-Sep-2007 espie <espie@openbsd.org>

move free_ohash function so that we can reuse it.


# 267e030a 16-Sep-2007 espie <espie@openbsd.org>

cut up dir.c into dir.c/direxpand.c as there is very little interface between
two modules that do different things.


# dac15098 24-Jul-2007 espie <espie@openbsd.org>

reindent (no binary change)


# 018b58ec 18-Jan-2007 espie <espie@openbsd.org>

* add an extra argument to the dir lookup functions to say whether we
should look in the current directory.
* refactor include files treatment to have a separate function to look
for an include.
* us

* add an extra argument to the dir lookup functions to say whether we
should look in the current directory.
* refactor include files treatment to have a separate function to look
for an include.
* use both pieces to make sure system includes do not get looked up
in the current directory unless everything else fails.

This is != from the netbsd solution to the same problem, which stuffs
`magic' entries into filepaths to say whether dot should be looked at
first or last.

feature requested by matthieu@.
okay matthieu@

show more ...


123