1feedbackd (0.0.0+git20211018) byzantium; urgency=medium
2
3  [ Evangelos Ribeiro Tzaras ]
4  * fbd-dev-sound: Honour sound theme name for all GNOME based desktops.
5  * d/control: Add json-glib-tools as build dependency.
6    This will make sure that the json theme file gets validated in CI.
7  * feedback-theme: Add phone-{hangup,failure,outgoing-busy} events.
8  * naming-spec: Fix upper cases, whitespaces and punctuation.
9
10  [ Andreas Hartmann ]
11  * fbd-feedback-manager: Make sure theme path components are '/' separated.
12  * README: Add explanation on custom theme paths.
13
14  [ Pablo Correa Gómez ]
15  * feedback-manager: Search for default theme under XDG_CONFIG_HOME first.
16    This would allow users to create their own feedback profiles
17  * Fix typos in documentation
18  * README: dbus calls not usable to trigger feedback.
19    Fixes #45
20
21  [ Guido Günther ]
22  * examples: Unbreak python example.
23  * docs: Fix --profile short option. It's '-P', not '-p'.
24  * cli: Fix changing global profile.
25  * feedback-theme: Add camera related events
26  * gitlab-ci: Switch to bullseye.
27  * fbd-dev-sound: Delay sending `ended` signal. This makes sure
28    we properly end the feedback even when looping.
29
30 -- Guido Günther <agx@sigxcpu.org>  Tue, 19 Oct 2021 13:13:43 +0200
31
32feedbackd (0.0.0+git20210426) byzantium; urgency=medium
33
34  [ Martin Bürgmann ]
35  * implement fbd_dev_sound_stop
36    tracks the FdbFeedbackSounds in a GHashTable in the FdbDevSound
37    (Closes: #10)
38
39  [ Guido Günther ]
40  * fbd-dev-sound: Don't leak GError
41  * fbd-dev-sound: Don't warn when sound was cancelled.
42    This is not an error per se.
43  * lfb-event: Don't leak error.
44    Don't leak the error values in the success case
45  * tests: Run lfb_event_{get,set}_timeout
46  * test-lfb-integration: Test invocation error
47  * event: Make log-domain match source file name
48  * tests: Run event tests too
49  * event: Remove 'g' prefix from common C types.
50    This matchs phosh's style.
51  * fbd-event: Add sender property.
52    This allows us to store the DBus sender
53  * fbd-manager: Keep DBus sender around
54  * feedback-manager: Track DBus clients and end feedbacks if they go away.
55    When the client goes away we build up a list of events to end feedback
56    for to make sure the hash table isn't modified in place. tThe alternative
57    approach would be to disconnect the on_event_feedbacks_ended handler,
58    duplicate the DBus signal emission and use g_hash_table_foreach_remove
59    but that looks less robust than using the same code path. (Closes: #25)
60  * Help emacs to indent properly
61  * fbd-feedback-theme: Don't leak JSON node
62  * fbd-dev-leds: Free actual FbdDevLed as well.
63    So far we only unref'ed the device.
64  * fbd-dev-leds: Don't leak enum_name
65    g_enum_to_string() is transfer full.
66  * fbd-dev-leds: Don't leak color
67    g_ascii_strdown() creates a copy already.
68  * fbd-dev-leds: Use automatic deep cleanup for device list.
69    The current logic was fragile and failed e.g. when the
70    FEEDBACKD_UDEV_VAL_LED would not match leaking the dev since the
71    g_object_unref() at the end of the loop was never hit.
72    Prevent that with automatic cleanup and explicitly ref'ing the
73    devs we want to use.
74  * fbd-dev-sound: Use correct cleanup for hash table.
75    This went unnoticed since the manager forgot to cleanup
76    this at all (see follow up commit).
77  * fbd-feedback-manager: Make sure to dispose sound device as well.
78    Fixes another leak.
79  * fbd-feedback-manager: Don't leak config_path.
80    It's assigned multiple times.
81  * fbd-feedback-manager: Don't leak device list
82
83  [ Clayton Craft ]
84  * fbd-ledctrl: fix matching of trigger in list of triggers.
85    If the trigger is the last thing in sysfs_path/LED_TRIGGER_ATTR, then
86    the new-line at the end of the output causes g_strv_contains to fail to
87    find the trigger in the list. This strips the new-line before splitting
88    the output into a list for searching.
89
90  [ Sebastian Spaeth ]
91  * README: Fix gdbus test command.
92    It is TriggerFeedback and not Feedback (anymore). Also add a note how to
93    end the feedback in order to prevent loss of hearing :-).
94
95 -- Guido Günther <agx@sigxcpu.org>  Mon, 26 Apr 2021 12:34:38 +0200
96
97feedbackd (0.0.0+git20210125) amber-phone; urgency=medium
98
99  [ Dylan Van Assche ]
100  * meson.build: compile GLib schemas on install.
101    Run a script as a post install to make sure that all GLib schemas are compiled
102  * fbd-feedback-manager: Allow device-specific feedbackd themes.
103
104  [ Guido Günther ]
105  * feedback-manager: Fix formatting.
106
107 -- Guido Günther <agx@sigxcpu.org>  Mon, 25 Jan 2021 10:50:15 +0100
108
109feedbackd (0.0.0+git20201114) amber-phone; urgency=high
110
111  [ Guido Günther ]
112  * sound: Set 'event' media role.  This allows pa to cork, duck, etc.
113  * gitlab-ci: Honor PKG_ONLY.  This allow us to get debs quicker
114  * udev: Update led maching for the librem5.  The names changed in device
115    tree which tickles up into userspace.
116  * debian: Don't abuse the video group.  Use a separate group for users that
117    should be able to access the LED devices.
118
119  [ Luca Weiss ]
120  * fbd-dev-leds: fix brightness parameter.
121    The fbd_dev_led_set_brightness function is only getting called with
122    parameter 0 at the moment so this was never noticed.
123  * Fix typos
124
125 -- Guido Günther <agx@sigxcpu.org>  Sat, 14 Nov 2020 15:54:23 +0100
126
127feedbackd (0.0.0+git20200726) amber-phone; urgency=medium
128
129  [ Arnaud Ferraris ]
130  * debian: udev: add support for PinePhone front LEDs
131  * fbd-dev-leds: store LED color when parsing devices.
132    Failing to do so will always select the first recognized LED (the blue
133    one for the PinePhone).
134
135  [ Guido Günther ]
136  * Release new git snapshot
137  * fbd-dev-sound: Be less verbose on missing sound files.
138    This is quite common so don't fill the logs at normal debug levels
139    but be more specific about what is missing.
140  * fbd-feedback-base: Add fbd_feedback_is_available ()
141    This allows to check if a feedback type is available
142    at all.
143  * feedback-manager: Fix indentation
144  * fbd-feedback-manager: Check if feedback is usable.
145    If we don't find any usable feedbacks for an event return
146    FBD_EVENT_END_REASON_NOT_FOUND.
147  * fbd-feedback-led: Implement is_available ()
148    This avoids criticals when there's no Leds available.
149  * feedback-vibra-rumble: Implement is_available.
150    This avoids criticals when there's no rumble vibra available.
151  * feedback-vibra-periodic: Implement is_available.
152    This avoids criticals when there's no periodic vibra available.
153  * feedback-sound: Implement is_available.
154    This avoids criticals when there's sound device available. We
155    can also be more precise about the reason why feedback ended.
156  * feedback-theme: Avoid warning when feedback is not found.
157    We tell the caller so debug level is enough
158  * tests: Don't check end reason in feedback handler.
159    This allows to reuse the feedback handler and we check the
160    reason in the actual test function anyway.
161  * tests: Test event not found case too
162  * feedback-manager: Deeply free the feedback list.
163    Instead of freeing each element after each iteration and then the list
164    itself at the very end just fully free the list. g_autoslist does
165    not work well on oder glib so do that manually.
166    This is just cosmetics.
167  * feedback-manager: Don't forget to remove not found events from the hash table.
168    This plugs a leak.
169  * feedback-manager: Dispose leds too
170  * feedback-led: Stop the correct led color
171  * feedback-led: Don't try to stop led when there's no led device.
172    This is not a critical since we prevented submitting initially
173    but daemon cleanup processes all entries in the theme.
174  * fbd: Dispose manager at the very end
175
176 -- Guido Günther <agx@sigxcpu.org>  Sun, 26 Jul 2020 13:05:59 +0200
177
178feedbackd (0.0.0+git20200714) amber-phone; urgency=medium
179
180  [ Arnaud Ferraris ]
181  * doc: fix typos
182  * doc: feedbackd: add short description.
183    Lintian issues a warning if short description is empty.
184  * fbd-ledctrl: fix typo
185
186  [ Guido Günther ]
187  * lfb-event: Clarify return values of `finished` functions.
188    They just inidicate that we talked to feedbackd successfully.
189  * lfb-event: Connect done handler in async case too.
190    Otherwise the event state is not updated properly
191  * tests: Don't quit mainloop on event end.
192    This is needed to properly test aync where we have the
193    finished async event handler and the signal.
194  * tests: Use async feedback as the test name implies
195
196 -- Guido Günther <agx@sigxcpu.org>  Tue, 14 Jul 2020 10:30:45 +0200
197
198feedbackd (0.0.0+git20200707) amber-phone; urgency=medium
199
200  [ Sebastian Krzyszkowiak ]
201  * data: Lower rumble time for window-close and button-pressed even more.
202    Haptic feedback for touchscreen input should be as subtle as possible
203    to not make it distracting.
204  * data: Add button-released event
205
206  [ Guido Günther ]
207  * feedback-sound: Plug a leak.
208    We did not free the effect name
209  * Doc cleanups
210  * feedback-manager: Only act on add.
211    We would otherwise ignore the action when no vibra device was yet found.
212    Make sure we release the old device when updating.
213  * libfeedback: Unset _initted early.
214    This make sure a client does not end up in our shutdown phase and sees a
215    half initted library.
216  * libfeedback: Cancel all running feedbacks on uninit.
217    We keep track of the active ids and end them on uninit. This
218    make sure feedbacks don't continue to run if the application quits
219    and forgets to end a feedback.
220  * fbcli: Quit main loop on CTRL-C / SIGTERM.
221    This makes sure we invoke the cleanup function correctly and allows
222    to test running event handling.
223  * docs: Add manpages (Closes: #12)
224  * data: Drop phone-missed-call in 'quiet' profile.  Only want LEDs there.
225  * feedbackd: Add helper to set up permissions for LEDs.
226    This helper knows about the triggers and necessary permission.
227    It's intended to be run via udev.
228  * debian: Setup leds via udev.
229    This allows feedbackd to set periodic feedback and makes usable
230    LED devices identifiable by feedbackd.
231  * feedbackd: Support visual feedback via LEDs.
232    later on by using the 'repeat' attribute of the LED pattern
233    trigger.
234  * data: Use LED feedback for missed calls, IMs and SMS
235  * Add generic missed notification.
236    This can be used e.g. by the shell for general purpose notifictions
237    but also for in app notifications of the foreground app.
238  * feedback-manager: Add hint to select feedback profile per event.
239    This e.g. allows events that are meant for haptic only to avoid
240    emitting a sound by omitting the 'full' level and using "quiet"
241    instead. (Closes: #7)
242  * LfbEvent: Add feedback-profile property.
243    This allows to specify the feedback profile to use for
244    this particular event.
245  * cli: Allow to set profile per event.
246    We allowed set the global profile via `-P` use it as per event
247    profile when used with `-E`.
248
249  [ Dorota Czaplejewicz ]
250  * build: Remove feedback dependencies from libfeedback builds
251
252 -- Guido Günther <agx@sigxcpu.org>  Fri, 10 Jul 2020 11:52:07 +0200
253
254feedbackd (0.0.0+git20200527) amber; urgency=medium
255
256  [ Rasmus Thomsen ]
257  * build: add proper dependencies on gdbus-codgen-generated headers.
258    Without this it was possible that ninja built a target that needs
259    the generated header before the header was generated
260
261  [ Guido Günther ]
262  * Release another git snapshot
263  * Honor sound theme on GNOME.
264    We don't set this for other DEs since they might want to pick a good
265    default from elsewhere.
266
267 -- Guido Günther <agx@sigxcpu.org>  Wed, 27 May 2020 10:00:08 +0200
268
269feedbackd (0.0.0+git20200420) amber; urgency=medium
270
271  [ Guido Günther ]
272  * Release another git snapshot
273  * Add symbols file
274  * theme: order feedbacks alphabetically.
275  * theme: Add feedbacks for window-close and button-press
276  * Allow to lower the feedback level per application.
277
278  [ Arnaud Ferraris ]
279  * d/control: customize short descriptions per binary package
280  * d/control: change feedbackd-common architecture to 'all'
281  * debian: rename gir package to match typelib name
282
283 -- Guido Günther <agx@sigxcpu.org>  Mon, 20 Apr 2020 09:55:33 +0200
284
285feedbackd (0.0.0+git20200305) amber-phone; urgency=medium
286
287  * feedbackd-common: Add proper Breaks/Replaces.
288    This handles partial upgrades with newer schema but old feebackd.
289
290 -- Guido Günther <agx@sigxcpu.org>  Mon, 23 Mar 2020 10:21:14 +0100
291
292feedbackd (0.0.0+git20200304) amber-phone; urgency=medium
293
294  [ Guido Günther ]
295  * libfeedback: Drop trailing semicolon.
296    Trips up some compilers.
297    Thanks to Andrea Schaefer
298  * build: Don't add lfb-enums.c to list of generated sources.
299    Otherwise when used as a subproject the master project will try
300    to rebuild with it's own set of flags. These lack
301    LIBFEEDBACK_COMPILATION which does not end well.
302  * Fix typos
303  * theme: Add timeout-completed event for alarms and stop watches
304  * Update docs (Closes: #4, #8)
305  * debian: Split out shared files.
306    This allows other programs (like gnome-control-center) to consume the
307    settings schema without having to depend on the daemon itself.
308
309  [ Rasmus Thomsen ]
310  * fbd-feedback-profile: use G_GSIZE_FORMAT instead of hardcoding lu.
311    On 32-bit platforms lu doesn't apply since GType is defined as a gsize
312    fixes #15
313
314 -- Guido Günther <agx@sigxcpu.org>  Wed, 04 Mar 2020 16:46:36 +0100
315
316feedbackd (0.0.0+git20200214) amber-phone; urgency=medium
317
318  * Initial git snapshot
319
320 -- Guido Günther <agx@sigxcpu.org>  Wed, 16 Oct 2019 21:22:33 +0200
321