1Source: mpatrol
2Section: devel
3Priority: optional
4Maintainer: Jerome Marant <jerome@debian.org>
5Build-Depends: debhelper (>> 3.0.0), binutils-dev
6Standards-Version: 3.5.2
7
8Package: mpatrol
9Architecture: any
10Depends: ${shlibs:Depends}
11Description: A powerful library for debugging memory allocations
12 The mpatrol library is a powerful debugging tool that attempts to
13 diagnose run-time errors that are caused by the wrong use of
14 dynamically allocated memory.
15 .
16 Along with providing a comprehensive and configurable log of all
17 dynamic memory operations that occurred during the lifetime of a
18 program, the mpatrol library performs extensive checking to detect
19 any misuse of dynamically allocated memory.
20 .
21 All of this functionality can be integrated into existing code
22 through the inclusion of a single header file at compile-time.
23 .
24 All logging and tracing output from the mpatrol library is sent
25 to a separate log file in order to keep its diagnostics separate
26 from any that the program being tested might generate.
27 .
28 A wide variety of library settings can also be changed at
29 run-time via an environment variable, thus removing the need to
30 recompile or relink in order to change the library's behaviour.
31 .
32 http://www.cbmamiga.demon.co.uk/mpatrol/
33