1# -*- coding: utf-8 -*-
2%define nasm_version 2.15.05
3Summary: The Netwide Assembler, a portable x86 assembler with Intel-like syntax
4Name: nasm
5Version: 2.15.05
6Release: 0%{?dist}
7License: BSD
8Source: http://www.nasm.us/pub/nasm/releasebuilds/%{nasm_version}/nasm-%{nasm_version}.tar.xz
9URL: http://www.nasm.us/
10BuildRoot: /tmp/rpm-build-nasm
11Prefix: %{_prefix}
12BuildRequires: perl(bytes)
13BuildRequires: perl(Fcntl)
14BuildRequires: perl(File::Basename)
15BuildRequires: perl(File::Compare)
16BuildRequires: perl(File::Copy)
17BuildRequires: perl(File::Find)
18BuildRequires: perl(File::Path)
19BuildRequires: perl(File::Spec)
20BuildRequires: perl(File::Temp)
21BuildRequires: perl(Font::TTF::Cmap)
22BuildRequires: perl(Font::TTF::Font)
23BuildRequires: perl(Font::TTF::Head)
24BuildRequires: perl(Font::TTF::Hmtx)
25BuildRequires: perl(Font::TTF::Maxp)
26BuildRequires: perl(Font::TTF::Post)
27BuildRequires: perl(Font::TTF::PSNames)
28BuildRequires: perl(Getopt::Long)
29BuildRequires: perl(Pod::Usage)
30BuildRequires: perl(sort)
31BuildRequires: perl(Sort::Versions)
32BuildRequires: autoconf
33BuildRequires: automake
34BuildRequires: asciidoc
35BuildRequires: xmlto
36BuildRequires: xz
37BuildRequires: perl
38BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
39
40%package doc
41Summary: Detailed manual for the Netwide Assembler
42BuildArch: noarch
43BuildRequires: ghostscript
44BuildRequires: fontconfig
45BuildRequires: adobe-source-sans-pro-fonts
46BuildRequires: adobe-source-code-pro-fonts
47
48%package rdoff
49Summary: Tools for the RDOFF binary format, sometimes used with NASM.
50
51%description
52NASM is the Netwide Assembler, a free portable assembler for the Intel
5380x86 microprocessor series, using primarily the traditional Intel
54instruction mnemonics and syntax.
55
56%description doc
57Extensive documentation for the Netwide Assembler (NASM) in HTML and
58PDF formats.
59
60%description rdoff
61Tools for the operating-system independent RDOFF binary format, which
62is sometimes used with the Netwide Assembler (NASM).  These tools
63include linker, library manager, loader, and information dump.
64
65%prep
66%setup -q -n nasm-%{nasm_version}
67
68%build
69sh autogen.sh
70%configure --enable-sections
71make %{?_smp_mflags} everything
72
73%install
74rm -rf "%{buildroot}"
75mkdir -p "%{buildroot}"/%{_bindir}
76mkdir -p "%{buildroot}"/%{_mandir}/man1
77make DESTDIR="%{buildroot}" install install_rdf
78
79%files
80%doc AUTHORS
81%{_bindir}/nasm
82%{_bindir}/ndisasm
83%{_mandir}/man1/nasm.1*
84%{_mandir}/man1/ndisasm.1*
85
86%files doc
87%doc doc/html doc/nasmdoc.pdf.xz
88
89%files rdoff
90%{_bindir}/ldrdf
91%{_bindir}/rdf2bin
92%{_bindir}/rdf2com
93%{_bindir}/rdf2ihx
94%{_bindir}/rdf2ith
95%{_bindir}/rdf2srec
96%{_bindir}/rdfdump
97%{_bindir}/rdflib
98%{_bindir}/rdx
99%{_mandir}/man1/ldrdf.1*
100%{_mandir}/man1/rd*.1*
101
102# This is the upstream spec file; the change log is in git
103%changelog
104