1%define name	xaw3dxft
2%define version	1.1
3%define release	1
4
5%define major 6
6%define libname %mklibname %{name} %{major}
7%define develname %mklibname %{name} -d
8
9Summary:	An extended version of Xaw3d
10Name:		%{name}
11Version:	%{version}
12Release:	%mkrel %{release}
13Group:		System/Libraries
14BuildRequires:	X11-devel
15BuildRequires:	bison
16BuildRequires:	flex
17BuildRequires:	imake
18BuildRequires:	gccmakedep
19Source0:	http://downloads.sourceforge.net/project/sf-xpaint/sf-xpaint/%{name}-%{version}/%{name}-%{version}.tar.bz2
20Url:		http://sourceforge.net/projects/sf-xpaint/
21License:	MIT
22BuildRoot:	%{_tmppath}/%{name}-%{version}-%{release}-buildroot
23
24%description
25An extended version of Xaw3d with support for UTF8 input
26and UTF8 encoding of text, and rendering text with the Freetype
27library and Truetype fonts.
28
29It should be mostly compatible with the original xaw3d library,
30except for font management: everything using the old X11 core
31font routines should be replaced by their freetype equivalents.
32
33%package -n	%{libname}
34Summary:	An extended version of Xaw3d
35Group:		System/Libraries
36Provides:	%{name} = %{version}-%{release}
37
38%description -n	%{libname}
39An extended version of Xaw3d with support for UTF8 input and
40UTF8 encoding of text, and rendering text with the Freetype
41library and Truetype fonts.
42
43It should be mostly compatible with the original Xaw3d library,
44except for font management: everything using the old X11 core
45font routines should be replaced by their freetype equivalents.
46
47%package -n	%{develname}
48Summary:	Header files and shared libraries for development using Xaw3dxft
49Group:		Development/C
50Requires:	%{libname} = %{version}-%{release}
51Provides:	%{name}-devel = %version-%release
52
53%description -n	%{develname}
54An extended version of Xaw3d with support for UTF8 input and
55UTF8 encoding of text, and rendering text with the Freetype
56library and Truetype fonts.
57
58It should be mostly compatible with the original Xaw3d library,
59except for font management: everything using the old X11 core
60font routines should be replaced by their freetype equivalents.
61
62You should install Xaw3dxft-devel if you are going to develop
63applications using the Xaw3dxft widget set.
64
65%prep
66%setup -q -c
67
68%build
69cd xaw3dxft-1.1
70xmkmf -a
71
72# fix compiler flags
73perl -pi -e 's|(CDEBUGFLAGS =.*)|CDEBUGFLAGS = %{optflags}|g' Makefile
74perl -pi -e 's|(CXXDEBUGFLAGS =.*)|CXXDEBUGFLAGS = %{optflags}|g' Makefile
75
76# fix overlinking
77sed -i -e 's|$(SMLIB)||g' Makefile
78sed -i -e 's|$(ICELIB)||g' Makefile
79sed -i -e 's|$(XPMLIB)||g' Makefile
80sed -i -e 's|$(XPLIB)||g' Makefile
81
82%make
83
84%install
85rm -rf %{buildroot}
86cd xaw3dxft-1.1
87%makeinstall_std
88
89%clean
90rm -rf %{buildroot}
91
92%files -n %{libname}
93%defattr(-,root,root)
94%{_libdir}/*.so.%{major}*
95
96%files -n %{develname}
97%defattr(-,root,root)
98%doc xaw3dxft-1.1/README*
99%{_libdir}/*.so
100%{_includedir}/X11/Xaw3dxft
101
102
103%changelog
104* Sun Mar 28 2010 Jani Välimaa <wally@mandriva.org> 1.1-1mdv2010.1
105+ Revision: 528551
106- import xaw3dxft
107
108
109