1%define _unpackaged_files_terminate_build 0
2%define debug_package %{nil}
3
4Release: 1
5
6%define openssldir /var/ssl
7
8Summary: Secure Sockets Layer and cryptography libraries and tools
9Name: openssl
10Version: 1.0.2k
11Source0: ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
12License: OpenSSL
13Group: System Environment/Libraries
14Provides: SSL
15URL: http://www.openssl.org/
16Packager: Damien Miller <djm@mindrot.org>
17BuildRoot:   /var/tmp/%{name}-%{version}-root
18
19%description
20The OpenSSL Project is a collaborative effort to develop a robust,
21commercial-grade, fully featured, and Open Source toolkit implementing the
22Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
23protocols as well as a full-strength general purpose cryptography library.
24The project is managed by a worldwide community of volunteers that use the
25Internet to communicate, plan, and develop the OpenSSL tookit and its related
26documentation.
27
28OpenSSL is based on the excellent SSLeay library developed from Eric A.
29Young and Tim J. Hudson.  The OpenSSL toolkit is licensed under an
30Apache-style licence, which basically means that you are free to get and
31use it for commercial and non-commercial purposes.
32
33This package contains the base OpenSSL cryptography and SSL/TLS
34libraries and tools.
35
36%package devel
37Summary: Secure Sockets Layer and cryptography static libraries and headers
38Group: Development/Libraries
39Requires: openssl
40%description devel
41The OpenSSL Project is a collaborative effort to develop a robust,
42commercial-grade, fully featured, and Open Source toolkit implementing the
43Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
44protocols as well as a full-strength general purpose cryptography library.
45The project is managed by a worldwide community of volunteers that use the
46Internet to communicate, plan, and develop the OpenSSL tookit and its related
47documentation.
48
49OpenSSL is based on the excellent SSLeay library developed from Eric A.
50Young and Tim J. Hudson.  The OpenSSL toolkit is licensed under an
51Apache-style licence, which basically means that you are free to get and
52use it for commercial and non-commercial purposes.
53
54This package contains the the OpenSSL cryptography and SSL/TLS
55static libraries and header files required when developing applications.
56
57%package doc
58Summary: OpenSSL miscellaneous files
59Group: Documentation
60Requires: openssl
61%description doc
62The OpenSSL Project is a collaborative effort to develop a robust,
63commercial-grade, fully featured, and Open Source toolkit implementing the
64Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
65protocols as well as a full-strength general purpose cryptography library.
66The project is managed by a worldwide community of volunteers that use the
67Internet to communicate, plan, and develop the OpenSSL tookit and its related
68documentation.
69
70OpenSSL is based on the excellent SSLeay library developed from Eric A.
71Young and Tim J. Hudson.  The OpenSSL toolkit is licensed under an
72Apache-style licence, which basically means that you are free to get and
73use it for commercial and non-commercial purposes.
74
75This package contains the the OpenSSL cryptography and SSL/TLS extra
76documentation and POD files from which the man pages were produced.
77
78%prep
79
80%setup -q
81
82%build
83
84%define CONFIG_FLAGS -DSSL_ALLOW_ADH --prefix=%{_exec_prefix} --openssldir=%{openssldir}
85
86perl util/perlpath.pl /usr/bin/perl
87
88%ifarch i386 i486 i586 i686
89./Configure %{CONFIG_FLAGS} linux-elf shared
90%endif
91%ifarch ppc
92./Configure %{CONFIG_FLAGS} linux-ppc shared
93%endif
94%ifarch alpha
95./Configure %{CONFIG_FLAGS} linux-alpha shared
96%endif
97%ifarch x86_64
98./Configure %{CONFIG_FLAGS} linux-x86_64 shared
99%endif
100LD_LIBRARY_PATH=`pwd` make
101LD_LIBRARY_PATH=`pwd` make rehash
102LD_LIBRARY_PATH=`pwd` make test
103
104%install
105rm -rf $RPM_BUILD_ROOT
106make MANDIR=%{_mandir} MANSUFFIX=ssl INSTALL_PREFIX="$RPM_BUILD_ROOT" install
107
108# Make backwards-compatibility symlink to ssleay
109ln -sf /usr/bin/openssl $RPM_BUILD_ROOT/usr/bin/ssleay
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%files
115%defattr(0644,root,root,0755)
116%doc CHANGES CHANGES.SSLeay LICENSE NEWS README
117
118%attr(0755,root,root) %{_bindir}/*
119%attr(0755,root,root) %{_libdir}/*.so*
120%attr(0755,root,root) %{_libdir}/engines/*.so*
121%attr(0755,root,root) %{_libdir}/pkgconfig/*
122%attr(0755,root,root) %{openssldir}/misc/*
123%attr(0644,root,root) %{_mandir}/man[157]/*
124
125%config %attr(0644,root,root) %{openssldir}/openssl.cnf
126%dir %attr(0755,root,root) %{openssldir}/certs
127%dir %attr(0755,root,root) %{openssldir}/misc
128%dir %attr(0750,root,root) %{openssldir}/private
129
130%files devel
131%defattr(0644,root,root,0755)
132%doc CHANGES CHANGES.SSLeay LICENSE NEWS README
133
134%attr(0644,root,root) %{_libdir}/*.a
135%attr(0644,root,root) %{_libdir}/pkgconfig/openssl.pc
136%attr(0644,root,root) %{_includedir}/openssl/*
137%attr(0644,root,root) %{_mandir}/man[3]/*
138
139%files doc
140%defattr(0644,root,root,0755)
141%doc CHANGES CHANGES.SSLeay LICENSE NEWS README
142%doc doc
143
144%post
145ldconfig
146
147%postun
148ldconfig
149
150%changelog
151* Sun Jun  6 2005 Richard Levitte <richard@levitte.org>
152- Remove the incorrect installation of '%{openssldir}/lib'.
153* Wed May  7 2003 Richard Levitte <richard@levitte.org>
154- Add /usr/lib/pkgconfig/openssl.pc to the development section.
155* Thu Mar 22 2001 Richard Levitte <richard@levitte.org>
156- Removed redundant subsection that re-installed libcrypto.a and libssl.a
157  as well.  Also remove RSAref stuff completely, since it's not needed
158  any more.
159* Thu Mar 15 2001 Jeremiah Johnson <jjohnson@penguincomputing.com>
160- Removed redundant subsection that re-installed libcrypto.so.0.9.6 and
161  libssl.so.0.9.6.  As well as the subsection that created symlinks for
162  these.  make install handles all this.
163* Sat Oct 21 2000 Horms <horms@vergenet.net>
164- Make sure symlinks are created by using -f flag to ln.
165  Otherwise some .so libraries are copied rather than
166  linked in the resulting binary RPM. This causes the package
167  to be larger than neccessary and makes ldconfig complain.
168* Fri Oct 13 2000 Horms <horms@vergenet.net>
169- Make defattr is set for files in all packages so packages built as
170  non-root will still be installed with files owned by root.
171* Thu Sep 14 2000 Richard Levitte <richard@levitte.org>
172- Changed to adapt to the new (supported) way of making shared libraries
173- Installs all static libraries, not just libRSAglue.a
174- Extra documents now end up in a separate document package
175* Sun Feb 27 2000 Damien Miller <djm@mindrot.org>
176- Merged patches to spec
177- Updated to 0.9.5beta2 (now with manpages)
178* Sat Feb  5 2000 Michal Jaegermann <michal@harddata.com>
179- added 'linux-alpha' to configuration
180- fixed nasty absolute links
181* Tue Jan 25 2000 Bennett Todd <bet@rahul.net>
182- Added -DSSL_ALLOW_ADH, bumped Release to 4
183* Thu Oct 14 1999 Damien Miller <djm@mindrot.org>
184- Set default permissions
185- Removed documentation from devel sub-package
186* Thu Sep 30 1999 Damien Miller <djm@mindrot.org>
187- Added "make test" stage
188- GPG signed
189* Tue Sep 10 1999 Damien Miller <damien@ibs.com.au>
190- Updated to version 0.9.4
191* Tue May 25 1999 Damien Miller <damien@ibs.com.au>
192- Updated to version 0.9.3
193- Added attributes for all files
194- Paramatised openssl directory
195* Sat Mar 20 1999 Carlo M. Arenas Belon <carenas@jmconsultores.com.pe>
196- Added "official" bnrec patch and taking other out
197- making a link from ssleay to openssl binary
198- putting all changelog together on SPEC file
199* Fri Mar  5 1999 Henri Gomez <gomez@slib.fr>
200- Added bnrec patch
201* Tue Dec 29 1998 Jonathan Ruano <kobalt@james.encomix.es>
202- minimum spec and patches changes for openssl
203- modified for openssl sources
204* Sat Aug  8 1998 Khimenko Victor <khim@sch57.msk.ru>
205- shared library creating process honours $RPM_OPT_FLAGS
206- shared libarry supports threads (as well as static library)
207* Wed Jul 22 1998 Khimenko Victor <khim@sch57.msk.ru>
208- building of shared library completely reworked
209* Tue Jul 21 1998 Khimenko Victor <khim@sch57.msk.ru>
210- RPM is BuildRoot'ed
211* Tue Feb 10 1998 Khimenko Victor <khim@sch57.msk.ru>
212- all stuff is moved out of /usr/local
213