1#!/usr/bin/make -f
2
3package=xphoon
4
5b=$(shell pwd)/debian/build
6i=$(shell pwd)/debian/tmp
7
8build:
9	xmkmf && make CCOPTIONS="-O2 -Wall -Dlint" && touch build
10
11clean:
12	-rm -f build
13	-make clean
14	-rm -f `find . -name "*~"` Makefile
15	-rm -rf debian/tmp debian/files* core debian/substvars
16
17install: build
18	dh_testdir
19	dh_testroot
20	dh_clean
21	rm -rf debian/build
22	mkdir -p debian/tmp/usr/doc/xphoon
23
24binary-indep: build install
25# There are no architecture-independent files to be uploaded
26# generated by this package.  If there were any they would be
27# made here.
28
29binary-arch:	build install \
30	xphoon
31
32xphoon: install
33	install -d $(i) -d $(i)/usr/games -d $(i)/usr/man/man6
34	install -s -m 755 $(package) $(i)/usr/games
35	install    -m 644 $(package).man $(i)/usr/man/man6/$(package).6x
36	dh_installdocs			README
37	dh_installchangelogs
38	dh_strip
39	dh_compress
40	dh_installmenu
41	dh_installmanpages
42	dh_fixperms
43	dh_installdeb
44	dh_shlibdeps
45	dh_gencontrol
46	dh_md5sums
47	dh_builddeb
48
49# Below here is fairly generic really
50
51binary:		binary-indep binary-arch
52
53.PHONY: binary binary-arch binary-indep clean
54