1pkgname=audacity-test
2pkgver=3.0.3
3pkgrel=1
4pkgdesc="Audacity is an easy-to-use, multi-track audio editor and recorder"
5groups=(audio)
6url="https://audacityteam.org"
7license=(GPL)
8
9arch=(x86_64)
10
11depends=(zlib
12   alsa-lib
13   gtk2
14   expat
15   libid3tag
16   libogg
17   libvorbis
18   flac
19   lame
20   twolame
21   libmad
22   libsndfile
23   jack
24   lilv
25   lv2
26   portaudio
27   portsmf
28   portmidi
29   suil
30   vamp-plugin-sdk
31   libsoxr
32   soundtouch
33   libpng
34   libjpeg-turbo
35   libsm
36)
37
38makedepends=(
39   git
40   cmake
41   python-pip
42   ffmpeg
43)
44
45optdepends=('ffmpeg: additional import/export capabilities')
46
47provides=(audacity audacity-test)
48conflicts=(audacity audacity-test)
49
50source=(
51  "audacity-sources.tar.gz"
52  "audacity-offline-dependencies-arch-linux.tar.gz"
53)
54
55md5sums=(
56  'SKIP'
57  'SKIP'
58)
59
60build() {
61    depsDir=$(readlink -f ./audacity-offline-dependencies)
62    python3 -m venv conan_env
63
64    source conan_env/bin/activate
65    pip3 install --no-index --find-links "$depsDir/pip_cache" conan
66
67    export CONAN_USER_HOME="$depsDir/conan_home"
68    mkdir -p $CONAN_USER_HOME
69
70    conan config home
71    conan config init
72    conan config set storage.download_cache="$CONAN_USER_HOME/download_cache"
73
74    cmake_args=(
75        -D CMAKE_BUILD_TYPE=Release
76        -D CMAKE_INSTALL_PREFIX=/usr
77
78        -D audacity_conan_allow_prebuilt_binaries=no
79
80        -D audacity_lib_preference=system # Change the libs default to 'system'
81        -D audacity_obey_system_dependencies=On # And force it!
82
83        -D audacity_use_pch=no
84
85        -D audacity_use_wxwidgets=local # wxWidgets 3.1 is not available
86
87        -D audacity_use_sbsms=local # sbsms is only available in AUR
88    )
89
90    cmake -S audacity -B build "${cmake_args[@]}"
91    cmake --build build -- -j`nproc`
92}
93
94package() {
95  cd build
96  make DESTDIR="$pkgdir/" install
97}
98