1# $Id: id3lib.spec.in,v 1.27 2002/11/02 18:03:27 t1mpy Exp $
2
3%define name    id3lib
4%define	version	3.8.3
5%define	release	1
6%define	prefix	/usr
7
8Name:		%{name}
9Version:	%{version}
10Release:	%{release}
11Summary:	A software library for manipulating ID3v1 and ID3v2 tags.
12Source:		http://download.sourceforge.net/id3lib/%{name}-%{version}.tar.gz
13URL:		http://id3lib.sourceforge.net
14Group:		System Environment/Libraries
15BuildRoot:	%{_tmppath}/%{name}-buildroot
16Copyright:	LGPL
17Prefix:         %{_prefix}
18Docdir:		%{prefix}/doc
19Requires:       zlib
20
21%description
22This package provides a software library for manipulating ID3v1 and ID3v2 tags.
23It provides a convenient interface for software developers to include
24standards-compliant ID3v1/2 tagging capabilities in their applications.
25Features include identification of valid tags, automatic size conversions,
26(re)synchronisation of tag frames, seamless tag (de)compression, and optional
27padding facilities. Additionally, it can tell mp3 header info, like bitrate etc.
28
29%package	devel
30Summary:	Headers for developing programs that will use id3lib
31Group:		Development/Libraries
32Requires:       %{name}
33
34%description	devel
35This package contains the headers that programmers will need to develop
36applications which will use id3lib, the software library for ID3v1 and ID3v2
37tag manipulation.
38
39%package        doc
40Summary:	Documentation for developing programs that will use id3lib
41Group:		Documentation
42
43%description	doc
44This package contains the documentation of the id3lib API that programmers will
45need to develop applications which will use id3lib, the software library for ID3v1
46and ID3v2 tag manipulation.
47
48%package        examples
49Summary:	Example applications that make use of the id3lib library
50Group:		Applications/File
51Requires:       %{name}
52
53%description	examples
54This package contains simple example applications that make use of id3lib, a
55software library for ID3v1 and ID3v2 tag manipulation.
56
57%prep
58%setup -q
59
60%build
61
62CXXFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%prefix --enable-debug=no
63
64%ifnarch noarch
65
66uname -a|grep SMP && make -j 2 || make
67
68%endif
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
73%ifnarch noarch
74
75make prefix=$RPM_BUILD_ROOT%{prefix} install
76
77%else
78
79make docs
80
81# strip down the doc and examples directories so we can copy w/impunity
82for i in doc/ examples/; do \
83  find $i                   \
84  \(  -name 'Makefile*' -or \
85      -name '*.ps.gz'   -or \
86      -name '*.pdf'         \
87  \)  -exec rm {} \; ; done
88
89%endif
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95
96%postun -p /sbin/ldconfig
97
98%ifnarch noarch
99
100%files
101%defattr(-, root, root)
102%doc AUTHORS COPYING ChangeLog HISTORY NEWS README THANKS TODO
103%{prefix}/lib/*.so.*
104
105%files devel
106%defattr(-, root, root)
107%doc AUTHORS COPYING ChangeLog HISTORY NEWS README THANKS TODO
108%{prefix}/include/id3*.h
109%{prefix}/include/id3
110%{prefix}/lib/*.la
111%{prefix}/lib/*.a
112%{prefix}/lib/*.so
113
114%files examples
115%defattr(-, root, root)
116%doc AUTHORS COPYING ChangeLog HISTORY NEWS README THANKS TODO
117%{prefix}/bin/id3*
118
119%else
120
121%files doc
122%defattr(-, root, root)
123%doc AUTHORS COPYING ChangeLog HISTORY NEWS README THANKS TODO
124%doc doc/*.* doc/api examples
125
126%endif
127
128%changelog
129* Sat Sep 08 2001 Cedric Tefft <cedric@earthling.net> 3.8.0pre2
130- Version 3.8.0pre2
131
132* Mon Nov 20 2000 Scott Thomas Haug <scott@id3.org> 3.8.0pre1-1
133- Version 3.8.0pre1
134
135* Thu Sep 14 2000 Scott Thomas Haug <scott@id3.org> 3.7.13-1
136- Version 3.7.13
137
138* Sat Aug 26 2000 Scott Thomas Haug <scott@id3.org> 3.7.12-2
139- Removed -mpreferred-stack-boundary option from RPM_OPT_FLAGS for RedHat 6.2
140
141* Fri Jul 07 2000 Scott Thomas Haug <scott@id3.org> 3.7.12-1
142- Version 3.7.12
143
144* Fri Jul 05 2000 Scott Thomas Haug <scott@id3.org> 3.7.11-1
145- Version 3.7.11
146
147* Fri Jun 23 2000 Scott Thomas Haug <scott@id3.org> 3.7.10-1
148- Version 3.7.10
149
150* Wed May 24 2000 Scott Thomas Haug <scott@id3.org> 3.7.9-1
151- Version 3.7.9
152
153* Wed May 10 2000 Scott Thomas Haug <scott@id3.org> 3.7.8-1
154- Version 3.7.8
155
156* Wed May 10 2000 Scott Thomas Haug <scott@id3.org> 3.7.7-1
157- Version 3.7.7
158
159* Wed May 03 2000 Scott Thomas Haug <scott@id3.org> 3.7.6-1
160- Version 3.7.6
161
162* Fri Apr 28 2000 Scott Thomas Haug <scott@id3.org> 3.7.5-1
163- Version 3.7.5
164
165* Wed Apr 26 2000 Scott Thomas Haug <scott@id3.org> 3.7.4-1
166- Version 3.7.4
167
168* Mon Apr 24 2000 Scott Thomas Haug <scott@id3.org> 3.7.3-1
169- Version 3.7.3
170- Added explicit RPM_OPT_FLAGS def based on arch, since -fno-exceptions and
171  -fno-rtti are part of the default flags in rpmrc and we need both exceptions
172  and rtti (exceptions uses rtti)
173
174* Fri Apr 21 2000 Scott Thomas Haug <scott@id3.org> 3.7.2-1
175- Version 3.7.2
176- More conditional blocks for noarch
177- More thorough cleaning of files for documentation
178- Updated html directory
179
180* Thu Apr 20 2000 Scott Thomas Haug <scott@id3.org> 3.7.1-2
181- Fixed date of changelog entry for 3.7.1-1
182- Added conditional blocks so docs only get built for noarch target
183
184* Wed Apr 19 2000 Scott Thomas Haug <scott@id3.org> 3.7.1-1
185- Version 3.7.1
186- Removed zlib-devel requirement from devel
187- Added doc package to distribute documentation
188- Added examples package to distribute binary examples (id3tag, id3info, ...)
189- Moved doc/ and examples/ source files from devel to doc package
190
191* Mon Apr 17 2000 Scott Thomas Haug <scott@id3.org> 3.7.0-1
192- First (s)rpm build
193