1# $Id: mp3-archive-tools.spec,v 1.4 2003/12/14 20:08:54 ianb Exp $
2
3%define perl_vendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo "$installvendorlib")
4
5Summary:        tools to maintain an archive of mp3 files
6
7Group:          Applications/Multimedia
8%define version 0.9
9%define real_version 0.9
10%define release 1
11
12%define name    mp3-archive-tools
13%define initdir %{_initrddir}
14
15Name: %{name}
16Version: %{version}
17Release: %{release}
18License: GPL
19BuildArchitectures: noarch
20Source: http://nessie.mcc.ac.uk/~ianb/projects/mp3-archive-tools/mp3-archive-tools-0.9.tar.gz
21Buildroot: %{_tmppath}/%{name}-root
22Prefix: %{_prefix}
23Requires: libmp3-archive-perl, perl-MP3-Tag
24
25%Description
26mp3-archive-tools is a set of tools to ease organising a collection of mp3
27(and other audio types) files.
28
29Tools included:
30mp3id                  - View/change id3 metadata. Supports ID3v2 and extended
31                         frames (pictures, etc).
32filenametoid3          - Update id3 metadata from filenames.
33id3tofilename          - Rename files based on id3 metadata.
34freedbtofilename       - Rename files based on data from freedb
35                         webpages (www.freedb.org).
36cddbtofilename         - Rename files based on data from cddb
37                         webpages (www.gracenote.com).
38movemusic              - Move music files to their correct place in
39                         your archive.
40update-music-symlinks  - Maintain a central link farm pointing to music
41                         in various places.
42pmv                    - Rename files using arbitrary perl code. Comes
43                         with a set of useful example commands.
44
45
46%prep
47%setup
48
49%build
50%{__perl} Makefile.PL INSTALLDIRS=vendor DESTDIR=$RPM_BUILD_ROOT/%{_prefix}
51make DESTDIR=$RPM_BUILD_ROOT/%{_prefix}
52
53%install
54[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
55make pure_install DESTDIR="$RPM_BUILD_ROOT"  INSTALLVENDORMAN1DIR=%{_mandir}/man1
56
57
58[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
59
60%files
61%defattr(-,root,root)
62%doc debian/changelog debian/copyright README examples/pmv-examples.sh
63%{_mandir}/man1/
64%{_bindir}/
65
66
67%clean
68[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
69
70%post
71
72%preun
73
74%changelog
75* Sun Nov 16 2003 Ian Beckwith <ianb@nessie.mcc.ac.uk>
76- Initial release
77