1# $Id: mp3lint.spec,v 1.9 2003/12/14 21:02:18 ianb Exp $
2
3%define perl_vendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo "$installvendorlib")
4
5Summary:        checks a directory tree of audio files for various problems
6
7Group:          Applications/Multimedia
8%define version 0.9
9%define real_version 0.9
10%define release 1
11
12%define name    mp3lint
13%define initdir %{_initrddir}
14
15Name: %{name}
16Version: %{version}
17Release: %{release}
18License: GPL
19BuildArchitectures: noarch
20Source: http://nessie.mcc.ac.uk/~ianb/projects/mp3lint/mp3lint-0.9.tar.gz
21Buildroot: %{_tmppath}/%{name}-root
22Prefix: %{_prefix}
23Requires: libmp3-archive-perl
24
25%Description
26mp3lint is a tool to check collections of audio files for various
27problems. It is highly configurable, allowing you to specify your
28preferred format for filenames, minimum bitrate, tests to ignore,
29etc. Formats checked are currently mp3, ogg, wav, flac, au, and m3u
30playlists.  mp3lint is implemented as separate tools (perl modules),
31each of which implements a set of tests. There are a total of 33
32different tests.
33
34
35%prep
36%setup
37
38%build
39%{__perl} Makefile.PL INSTALLDIRS=vendor DESTDIR=$RPM_BUILD_ROOT/%{_prefix}
40make DESTDIR=$RPM_BUILD_ROOT/%{_prefix}
41
42%install
43[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
44make pure_install DESTDIR="$RPM_BUILD_ROOT"  INSTALLVENDORMAN1DIR=%{_mandir}/man1 INSTALLVENDORMAN3DIR=%{_mandir}/man3 INSTALLVENDORMAN5DIR=%{_mandir}/man5
45
46
47
48[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
49
50%files
51%defattr(-,root,root)
52%doc debian/changelog debian/copyright README
53%config(noreplace) %attr(644,root,root) /etc/mp3lintrc
54%{_mandir}/man1/
55%{_mandir}/man3/
56%{_mandir}/man5/
57%{perl_vendorlib}/MP3
58%{_bindir}/mp3lint
59%{_bindir}/mp3lintskip
60%{_bindir}/mp3lintsum
61
62%clean
63[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
64
65%post
66
67%preun
68
69%changelog
70* Wed Nov 5 2003 Ian Beckwith <ianb@nessie.mcc.ac.uk>
71- Attempts to fix rpm problems
72
73* Mon Oct 27 2003 Ian Beckwith <ianb@nessie.mcc.ac.uk>
74- Initial release
75