1%define name    sweep
2%define version 0.9.3
3%define release 1
4%define prefix  /usr
5
6Summary: Sound wave editor
7
8Name:           %{name}
9Version:        %{version}
10Release:        %{release}
11Copyright:      GPL
12Group:          Applications/Sound
13URL:            http://sweep.sourceforge.net/
14
15Source:         %{name}-%{version}.tar.gz
16Buildroot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17Docdir:         %{prefix}/doc
18Prefix:         %{prefix}
19Requires:       gtk+ >= 2.2.0
20
21%description
22Sweep is an editor for sound samples. It operates on files of various
23formats such as .wav, .aiff and .au, and has multiple undo/redo levels
24and filters. It supports audio filter plugins from the LADSPA project.
25
26%package        devel
27Summary:        Sweep plugin development kit
28Group:          Applications/Sound
29Requires:       %{name} = %{version}
30
31%description    devel
32The sweep-devel package contains header files and documentation for writing
33plugins for Sweep, a sound wave editor.
34
35Install sweep-devel if you're going to create plugins for Sweep. You will
36also need to install sweep.
37
38%prep
39%setup -q -n %{name}-%{version}
40if [ -f configure ]; then
41        CFLAGS=$RPM_OPT_FLAGS \
42        ./configure --prefix=%{prefix};
43else
44        CFLAGS=$RPM_OPT_FLAGS \
45        ./autogen.sh --prefix=%{prefix};
46fi
47
48%build
49LINGUAS="fr hu it de pl" CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{prefix}
50gmake
51
52%install
53if [ -d $RPM_BUILD_ROOT ]; then rm -r $RPM_BUILD_ROOT; fi
54mkdir -p $RPM_BUILD_ROOT%{prefix}
55make prefix=$RPM_BUILD_ROOT%{prefix} install-strip
56
57%files
58
59%defattr (0555, bin, bin)
60%{prefix}/bin/sweep
61
62%defattr (0444, bin, bin, 0555)
63%{prefix}/lib/sweep/libladspameta*
64%{prefix}/lib/sweep/libecho*
65%{prefix}/lib/sweep/libnormalise*
66%{prefix}/lib/sweep/libreverse*
67%{prefix}/lib/sweep/libbyenergy*
68
69%defattr (0555, bin, man)
70%{prefix}/man/man1/sweep.1*
71%doc ABOUT-NLS NEWS README ChangeLog
72%doc README.Solaris README.ALSA
73%doc doc/*.txt
74
75%defattr (-, root, root)
76%{prefix}/share/gnome/apps/Multimedia/sweep.desktop
77%{prefix}/share/locale/*/*/*
78
79%files devel
80%doc doc/plugin_writers_guide.txt
81%{prefix}/include/sweep/
82
83%clean
84rm -r $RPM_BUILD_ROOT
85
86%changelog
87* Sun Oct 08 2000 Conrad Parker <conrad@vergenet.net>
88- updated for sweep version 0.1.0
89- added devel package
90- added packaging of plugins
91- added documentation
92
93* Tue Aug 09 2005 Peter Shorthose <kickback@users.sourceforge.net>
94- use autoconf to generate the spec via sweep.spec.in
95- insert the package version via the autoconf macro
96- remind the reader that the above changes are untested as of now
97
98* Thur Aug 25 2005 Peter Shorthose <kickback@users.sourceforge.net>
99- update Gtk requirements
100