1/* -*- c -*- */
2/*****************************************************************************/
3/*  LibreDWG - free implementation of the DWG file format                    */
4/*                                                                           */
5/*  Copyright (C) 2020 Free Software Foundation, Inc.                        */
6/*                                                                           */
7/*  This library is free software, licensed under the terms of the GNU       */
8/*  General Public License as published by the Free Software Foundation,     */
9/*  either version 3 of the License, or (at your option) any later version.  */
10/*  You should have received a copy of the GNU General Public License        */
11/*  along with this program.  If not, see <http://www.gnu.org/licenses/>.    */
12/*****************************************************************************/
13
14/*
15 * filedeplist.spec: AcDb:FileDepList section specification
16 * written by Reini Urban
17 */
18
19  #include "spec.h"
20
21  FIELD_RL (num_features, 0);
22  FIELD_VECTOR_T (features, TU32, num_features, 0);
23  FIELD_RL (num_files, 0);
24  REPEAT (num_files, files, Dwg_FileDepList_Files)
25  REPEAT_BLOCK
26    FIELD_T32 (files[rcount1].filename, 0);
27    FIELD_T32 (files[rcount1].filepath, 0);
28    FIELD_T32 (files[rcount1].fingerprint, 0);
29    FIELD_T32 (files[rcount1].version, 0);
30    FIELD_RL (files[rcount1].feature_index, 0);
31    FIELD_RL (files[rcount1].timestamp, 0);
32    FIELD_RL (files[rcount1].filesize, 0);
33    FIELD_RS (files[rcount1].affects_graphics, 0);
34    FIELD_RL (files[rcount1].refcount, 0);
35  END_REPEAT_BLOCK
36  END_REPEAT (files)
37