1/* -*- c -*- */
2/*****************************************************************************/
3/*  LibreDWG - free implementation of the DWG file format                    */
4/*                                                                           */
5/*  Copyright (C) 2020 Free Software Foundation, Inc.                        */
6/*                                                                           */
7/*  This library is free software, licensed under the terms of the GNU       */
8/*  General Public License as published by the Free Software Foundation,     */
9/*  either version 3 of the License, or (at your option) any later version.  */
10/*  You should have received a copy of the GNU General Public License        */
11/*  along with this program.  If not, see <http://www.gnu.org/licenses/>.    */
12/*****************************************************************************/
13
14/*
15 * revhistory.spec: AcDb:RevHistory section specification
16 * written by Reini Urban
17 */
18
19  #include "spec.h"
20
21  FIELD_RL (class_version, 0);
22  FIELD_RL (class_minor, 0);
23  FIELD_RL (num_histories, 0);
24  REPEAT (num_histories, histories, BITCODE_RL)
25  REPEAT_BLOCK
26    FIELD_RL (histories[rcount1], 0);
27  END_REPEAT_BLOCK
28  END_REPEAT (histories)
29