1/* -*- c -*- */
2/*****************************************************************************/
3/*  LibreDWG - free implementation of the DWG file format                    */
4/*                                                                           */
5/*  Copyright (C) 2020 Free Software Foundation, Inc.                        */
6/*                                                                           */
7/*  This library is free software, licensed under the terms of the GNU       */
8/*  General Public License as published by the Free Software Foundation,     */
9/*  either version 3 of the License, or (at your option) any later version.  */
10/*  You should have received a copy of the GNU General Public License        */
11/*  along with this program.  If not, see <http://www.gnu.org/licenses/>.    */
12/*****************************************************************************/
13
14/*
15 * security.spec: AcDb:Security section specification,
16 * when saved with a password.
17 * written by Reini Urban
18 */
19
20  #include "spec.h"
21
22  FIELD_RLx (unknown_1, 0);
23  FIELD_RLx (unknown_2, 0);
24  FIELD_RLx (unknown_3, 0);
25  FIELD_RL (crypto_id, 0);
26  FIELD_T32 (crypto_name, 0);
27  FIELD_RL (algo_id, 0);
28  FIELD_RL (key_len, 0);
29  FIELD_RL (encr_size, 0);
30  FIELD_BINARY (encr_buffer, FIELD_VALUE (encr_size), 0);
31