1Summary:	State Threads Library
2Name:		st
3Version:	1.9
4Release:	1
5Copyright:	MPL 1.2 or GPL 2+
6Packager:	Wesley W. Terpstra <wesley@terpstra.ca>
7Source:		http://prdownloads.sourceforge.net/state-threads/st-%{version}.tar.gz
8Prefix:		/usr
9BuildRoot:	/tmp/%{name}-%{version}-build
10Group:		Development/Libraries
11
12%description
13The State Threads library has an interface similar to POSIX threads.
14
15However, the threads are actually all run in-process. This type of
16threading allows for controlled schedualing points. It is highly useful
17for designing robust and extremely scalable internet applications since
18there is no resource contention and locking is generally unnecessary.
19
20It can be combined with traditional threading or multiple process
21parallelism to take advantage of multiple processors.
22
23See: <http://state-threads.sourceforge.net/docs/st.html> for further
24information about how state threads improve performance.
25
26%package -n libst-devel
27Summary:	State Threads Library - Development Files
28Group:		Development/Libraries
29Requires:	libst1
30
31%description -n libst-devel
32Development headers and documentation for libst
33
34%package -n libst1
35Summary:	State Threads Library - Shared Libs Major 1
36Group:		System/Libraries
37
38%description -n libst1
39Shared libraries for running applications linked against api version 1.
40
41%prep
42%setup -q
43
44%build
45make CONFIG_GUESS_PATH=/usr/share/automake default-optimized
46
47%install
48if [ -d ${RPM_BUILD_ROOT} ]; then rm -rf ${RPM_BUILD_ROOT}; fi
49
50mkdir -m 0755 -p ${RPM_BUILD_ROOT}/%{prefix}/lib/pkgconfig
51mkdir -m 0755 -p ${RPM_BUILD_ROOT}/%{prefix}/include
52mkdir -m 0755 -p ${RPM_BUILD_ROOT}/%{prefix}/share/doc/libst-devel
53cp -a obj/libst.* ${RPM_BUILD_ROOT}/%{prefix}/lib
54cp -a obj/st.h    ${RPM_BUILD_ROOT}/%{prefix}/include
55sed "s*@prefix@*%{prefix}*g" <st.pc >${RPM_BUILD_ROOT}/%{prefix}/lib/pkgconfig/st.pc
56cp -a docs/*      ${RPM_BUILD_ROOT}/%{prefix}/share/doc/libst-devel/
57cp -a examples    ${RPM_BUILD_ROOT}/%{prefix}/share/doc/libst-devel/
58
59%post -n libst1
60/sbin/ldconfig %{prefix}/lib
61
62%files -n libst1
63%defattr(-,root,root)
64%{prefix}/lib/lib*.so.*
65
66%files -n libst-devel
67%defattr(-,root,root)
68%{prefix}/include/*
69%{prefix}/lib/lib*.a
70%{prefix}/lib/lib*.so
71%{prefix}/lib/pkgconfig/st.pc
72%{prefix}/share/doc/libst-devel/*
73
74%clean
75if [ -d ${RPM_BUILD_ROOT} ]; then rm -rf ${RPM_BUILD_ROOT}; fi
76
77%changelog
78* Wed Dec 26 2001 Wesley W. Terpstra <wesley@terpstra.ca>
79- first rpms for libst-1.3.tar.gz
80