1#
2# Makefile.nix
3#
4# This is a *bare minimum* makefile for building gnuboy on *nix systems.
5# If you have trouble with the configure script you can try using this,
6# but *please* try the configure script first. This file is mostly
7# unmaintained and may break.
8#
9# If you *do* insist on using this makefile, you at least need to check
10# SYS_DEFS below and uncomment -DIS_LITTLE_ENDIAN if your system is
11# little endian. Also, you may want to enable the OSS sound module if
12# your system supports it.
13#
14
15prefix = /usr/local
16bindir = /bin
17
18CC = gcc
19AS = $(CC)
20LD = $(CC)
21INSTALL = /bin/install -c
22
23CFLAGS = -O3
24LDFLAGS =
25ASFLAGS =
26
27SYS_DEFS = #-DIS_LITTLE_ENDIAN
28ASM_OBJS =
29#SND_OBJS = sys/oss/oss.o
30SND_OBJS = sys/dummy/nosound.o
31JOY_OBJS = sys/dummy/nojoy.o
32
33TARGETS = xgnuboy
34
35SYS_OBJS = sys/nix/nix.o $(ASM_OBJS) $(SND_OBJS) $(JOY_OBJS)
36SYS_INCS = -I/usr/local/include -I/usr/X11R6/include -I./sys/nix
37
38X11_OBJS = sys/x11/xlib.o sys/x11/keymap.o
39X11_LIBS = -L/usr/X11R6/lib -lX11 -lXext
40
41all: $(TARGETS)
42
43include Rules
44
45xgnuboy: $(OBJS) $(SYS_OBJS) $(X11_OBJS)
46	$(LD) $(LDFLAGS) $(OBJS) $(SYS_OBJS) $(X11_OBJS) -o $@ $(X11_LIBS)
47
48install: all
49	$(INSTALL) -m 755 $(TARGETS) $(prefix)$(bindir)
50
51clean:
52	rm -f *gnuboy gmon.out *.o sys/*.o sys/*/*.o asm/*/*.o
53
54
55
56
57
58
59
60
61
62
63
64
65