1#!/bin/sh
2
3set -e
4# summary of how this script can be called:
5#        * <postinst> `configure' <most-recently-configured-version>
6#        * <old-postinst> `abort-upgrade' <new version>
7#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
8#          <new-version>
9#        * <postinst> `abort-remove'
10#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
11#          <failed-install-package> <version> `removing'
12#          <conflicting-package> <version>
13# for details, see http://www.debian.org/doc/debian-policy/ or
14# the debian-policy package
15
16case "$1" in
17    configure)
18	for p in mozilla firefox iceweasel xulrunner midbrowser; do
19	    if test -d "/usr/lib/$p/plugins"; then
20		update-alternatives --install \
21		    "/usr/lib/$p/plugins/flashplugin-alternative.so" \
22		    "$p-flashplugin" \
23		    /usr/lib/mozilla/plugins/libgnashplugin.so \
24		    10;
25	    fi
26	done
27        ;;
28    abort-upgrade|abort-remove|abort-deconfigure)
29        ;;
30
31    *)
32        echo "postinst called with unknown argument \`$1'" >&2
33        exit 1
34        ;;
35esac
36
37# dh_installdeb will replace this with shell code automatically
38# generated by other debhelper scripts.
39
40#DEBHELPER#
41
42exit 0
43
44