1#
2# This spec file is specific to the ltib build system
3#
4%define pfx /opt/freescale/rootfs/%{_target_cpu}
5
6Name:           gnash
7Version:        20110912
8Release:        0
9Epoch: 		0
10Distribution:	ltib
11Summary:        GNU SWF player
12
13Group:          Applications/Multimedia
14Vendor:		Gnash Project
15Packager:	Rob Savoye <rob@senecass.com>
16License:        GPLv3
17URL:            http://www.gnu.org/software/gnash/
18Source:         gnash-%{version}.tar.bz2
19BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-%{_target_cpu}
20
21# BuildRequires:  ffmpeg libpng libjpeg giflib boost agg curl freetype libstdc++ fontconfig
22Prefix:         /usr
23
24Requires(post): /sbin/ldconfig
25Requires(postun): /sbin/ldconfig
26
27%description
28Gnash is a GNU SWF movie player that supports many SWF v7 features,
29with growing support for swf v8, v9, and v10.
30Requires:  ffmpeg libpng libjpeg giflib boost curl freetype
31
32%prep
33%setup -q
34
35%build
36
37# Allow to change the sysroot path used by Gnash to find all headers and libraries
38# using a GNASH_SYSROOT environment variable
39if test x"${GNASH_SYSROOT}" = x; then
40  # If no default sysroot is specified, look for one that should be at this location
41  absroot=`cd ../../../rootfs/usr/ ; pwd`
42  echo "GNASH_SYSROOT not set in the users environment, using \"${absroot}\" for sysroot"
43  CROSS_OPTS="--host=arm-none-linux-gnueabi --with-sysroot=$absroot"
44else
45  CROSS_OPTS="--host=arm-none-linux-gnueabi --with-sysroot=${GNASH_SYSROOT}"
46fi
47
48# uncommenting these will produce huge volumes of debug info from the
49# shell, but sometimes that's what you need to do.
50# export CONFIG_SHELL="sh -x"
51sh ./configure \
52	$CROSS_OPTS \
53        --prefix=/usr \
54	--mandir=%{_prefix}/share/man \
55	--infodir=%{_prefix}/share/info \
56	--disable-dependency-tracking \
57	--disable-testsuite \
58	--disable-rpath \
59        --disable-jemalloc \
60        --enable-gui=fb \
61	--disable-sound \
62        --enable-media=ffmpeg \
63        --enable-renderer=ovg \
64        --enable-device=egl,rawfb  \
65        CXXFLAGS='-g -O0'
66# Only uncomment this for debugging
67#        2>&1 | tee tmp/xxx
68
69make $MAKEFLAGS all -w
70make $MAKEFLAGS -C libdevice check -w
71make $MAKEFLAGS -C librender check -w
72
73# When testing the spec file, try setting MAKEFLAGS to
74# "CXXFLAGS-O0 -j4" to speed up getting results. Note *don't*
75# do that for release builds, as the performance will suffer.
76
77%install
78#strip gui/.libs/*-gnash
79rm -rf $RPM_BUILD_ROOT
80make $MAKEFLAGS install DESTDIR=$RPM_BUILD_ROOT
81rm $RPM_BUILD_ROOT%{_libdir}/gnash/*.*a
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%post
86/sbin/ldconfig
87
88%preun
89if [ $1 = 0 ]; then
90    /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
91fi
92
93%postun
94/sbin/ldconfig
95
96%files
97%defattr(-,root,root,-)
98%{_bindir}/fb-gnash
99%defattr(-,root,root,-)
100#%dump
101%doc README AUTHORS COPYING NEWS
102%{_bindir}/gnash
103%{_bindir}/gprocessor
104#%{_bindir}/dumpshm
105%{_bindir}/rtmpget
106%{_libdir}/gnash/*.so*
107%{_prefix}/share/gnash/GnashG.png
108%{_prefix}/share/gnash/gnash_128_96.ico
109%{_datadir}/locale/*/LC_MESSAGES/gnash.mo
110
111%changelog
112* Sat Nov 30 2010 Rob Savoye <rob@welcomehome.org> - %{version}-%{release}
113- Drop most of the packages for ltib builds.
114
115* Sat Mar 27 2010 Rob Savoye <rob@welcomehome.org> - %{version}-%{release}
116- add gnash-common package for non GUI files so as not to contaminate
117  the gtk or kde packages.
118
119* Sat Sep 07 2009 Rob Savoye <rob@welcomehome.org> - %{version}-%{release}
120- add kde4 support for klash.
121
122* Sat Jun 13 2009 Rob Savoye <rob@welcomehome.org> - trunk
123- Add support for packaging the gtk & python widget
124
125* Sat Feb 13 2009 Rob Savoye <rob@welcomehome.org> - trunk
126- Split off klash into it's own spec file.
127
128* Sat Oct 24 2008 Rob Savoye <rob@welcomehome.org> - trunk
129- Adjust dependencies for current bzr trunk
130
131* Sat Feb  16 2008 Rob Savoye <rob@welcomehome.org> - %{version}-%{release}
132- Adjust dependencies for current cvs HEAD
133
134* Sat Mar  6 2007 Rob Savoye <rob@welcomehome.org> - %{version}-%{release}
135- merge in patch from John @ Redhat.
136
137* Tue Mar 06 2007 John (J5) Palmieri <johnp@redhat.com> 0.7.2.cvs20070306-1
138- update to new snapshot
139
140* Thu Feb 28 2007 John (J5) Palmieri <johnp@redhat.com> 0.7.2.cvs20070226-3
141- require xulrunner instead of webclient
142
143* Wed Feb 28 2007 John (J5) Palmieri <johnp@redhat.com> 0.7.2.cvs20070226-2
144- don't delete requires .so files
145
146* Mon Feb 26 2007 John (J5) Palmieri <johnp@redhat.com> 0.7.2.cvs20070226-1
147- cvs snapshot built for olpc
148
149* Sat Nov  7 2006 Rob Savoye <rob@welcomehome.org> - 0.7.2-2
150- update for 0.7.2 release.
151
152* Sat Nov  6 2006 Patrice Dumas <pertusus@free.fr> 0.7.2-1
153- update for 0.7.2 release.
154
155* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.7.1-9
156 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
157
158* Sun Sep 24 2006 Patrice Dumas <pertusus@free.fr> 0.7.1-8
159- plugin requires %%{_libdir}/mozilla/plugins. Fix (incompletly and
160  temporarily, but there is no better solution yet) #207613
161
162* Sun Aug 27 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-7
163- add defattr for klash
164- add warnings in the description about stability
165
166* Mon Aug 21 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-6
167- remove superfluous buildrequires autoconf
168- rename last patch to gnash-plugin-tempfile-dir.patch
169- add README.fedora to plugin to explain tmpdirs
170
171* Wed Aug 16 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-5
172- source qt.sh and configure --with-qtdir (Dominik Mierzejewski)
173- add plugin-tempfile-dir.patch for plugin to use a safe tempdir
174
175* Fri Jul 28 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-4
176- buildrequire autotools (Michael Knox)
177
178* Fri Jun  2 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-3
179- add gnash-continue_on_info_install_error.patch to avoid
180- buildrequire libXmu-devel
181
182* Wed May 17 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-2
183- configure with --disable-rpath
184- buildrequire docbook2X
185- remove devel files
186
187* Sun May  7 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-1
188- update to 0.7.1 alpha release
189
190* Sat Apr  22 2006 Rob Savoye <rob@welcomehome.org> - 0.7-1
191- install the info file. Various tweaks for my system based on
192Patrice's latest patch,
193
194* Fri Feb  3 2006 Patrice Dumas <dumas@centre-cired.fr> - 0.7-0
195- initial packaging
196
197