1Description:fix nickident.pl to work with dancer-services and
2fix typo in parsing ircd responses
3Forwarded: no
4Author: The Fungi <fungi@yuggoth.org>
5Last-Update: 2008-03-23
6--- a/scripts/nickident.pl
7+++ b/scripts/nickident.pl
8@@ -91,9 +91,9 @@
9 			Irssi::signal_stop();
10 		} elsif ($text =~ /nick, type.+msg NickServ IDENTIFY.+password.+Otherwise,|please choose a different nick./i) {
11 			Irssi::signal_stop();
12-		} elsif ($text =~ /Password accepted - you are now recognized./ ||
13+		} elsif ($text =~ /Password accepted - you are now recognized/ ||
14 		         $text =~ /Wow, you managed to remember your password.  That's a miracle by your usual standard./ ||
15-		 	 $text =~ /You are sucessfully identified as/ ) {
16+		 	 $text =~ /You are successfully identified as/ ) {
17 			Irssi::print("$name: Got a positive response from $nick/" . $server->{'tag'});
18 			join_channels($server);
19 			Irssi::signal_stop();
20