1Summary: A simple program that emulates the detach feature of screen.
2Name: dtach
3Version: 0.9
4Release: 1
5License: GPL
6URL: http://dtach.sourceforge.net
7Group: Applications/System
8Source: http://prdownloads.sourceforge.net/dtach/dtach-%{version}.tar.gz
9Buildroot: %{_tmppath}/%{name}-%{version}-root
10
11%description
12
13dtach is a program that emulates the detach feature of screen, with
14less overhead.  It is designed to be transparent and un-intrusive; it
15avoids interpreting the input and output between attached terminals
16and the program under its control. Consequently, it works best with
17full-screen applications such as emacs.
18
19%prep
20%setup
21
22%build
23%configure
24make
25
26%install
27rm -rf $RPM_BUILD_ROOT/*
28mkdir -p $RPM_BUILD_ROOT/%{_bindir}
29mkdir -p $RPM_BUILD_ROOT/usr/share/doc/dtach-%{version}
30mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
31install -m 755 dtach $RPM_BUILD_ROOT/%{_bindir}/dtach
32install -m 644 dtach.1 $RPM_BUILD_ROOT/%{_mandir}/man1/dtach.1
33
34%clean
35make clean
36rm -rf $RPM_BUILD_ROOT
37rm -rf $RPM_BUILD_DIR/%{name}-%{version}
38
39%files
40%defattr(-,root,root,-)
41%doc COPYING README
42%{_bindir}/dtach
43%{_mandir}/*/*
44
45%changelog
46* Sun May 8 2016 Ned T. Crigler <crigler@users.sourceforge.net> 0.9
47- New release
48
49* Wed Jan 30 2008 Ned T. Crigler <crigler@users.sourceforge.net> 0.8
50- New release
51
52* Sat Jul 3 2004 Ned T. Crigler <crigler@users.sourceforge.net> 0.7
53- New release
54
55* Fri Nov 30 2001 Ned T. Crigler <crigler@hell-city.org> 0.5
56- Fix fd leakage.
57- Prevent atexit from being called twice on dtach -A.
58
59* Fri Nov 30 2001 Trond Eivind Glomsrd <teg@redhat.com> 0.4-1
60- s/Copyright/License/
61- Minor description change
62- fix use of %%doc
63- Add full location of source tarball
64
65* Sat Nov 03 2001 Ned T. Crigler <crigler@hell-city.org> 0.4
66- Portability updates thanks to sourceforge's compile farm. dtach should now
67  work on: FreeBSD, Debian/alpha, Debian/PPC, Debian/sparc, Debian/PPC, and
68  Solaris.
69
70* Thu Sep 27 2001 Ned T. Crigler <crigler@hell-city.org>
71- Modified spec file URL: to point to http://dtach.sourceforge.net
72
73* Wed Sep 26 2001 Ned T. Crigler <crigler@hell-city.org> 0.3
74- Use getrlimit and dynamically allocate the data structures, if possible.
75- Added some more autoconf checks.
76- Initial sourceforge release.
77
78* Thu Sep 20 2001 Ned T. Crigler <crigler@hell-city.org>
79- Changed the master to send a stream of text to attaching clients instead
80  of sending a huge packet all the time.
81- Decreased the client <-> master packet size.
82- Changed the attach code so that it tells the master when a suspend occurs.
83
84* Tue Sep 18 2001 Ned T. Crigler <crigler@hell-city.org>
85- Fixed a typo in dtach.1
86
87* Tue Sep 18 2001 Ned T. Crigler <crigler@hell-city.org> 0.2
88- Removed silly thinko regarding terminal settings in attach, we
89  always set the terminal to raw mode now.
90- Moved redraw code into the master, which tries to be smarter when
91  using ^L.
92- Moved the code that obtains the current terminal settings into main,
93  preventing a race condition between the master and attach processes.
94- Rewrote argument parsing code.
95- Changed name to dtach.
96- Added a man page.
97
98* Mon Sep 17 2001 Ned T. Crigler <crigler@hell-city.org>
99- Changed fchmod to chmod in create_socket.
100
101* Mon Sep 17 2001 Isaiah Weiner <iweiner@redhat.com>
102- Modified spec file to correct detach binary permissions
103- Modified spec file to correct detach documentation path
104- Modified spec file URL: to point to http://people.redhat.com/iweiner/detach
105- Modified spec file %clean to remove buildroot and builddir.
106
107* Mon Sep 17 2001 Ned T. Crigler <crigler@hell-city.org> 0.1
108- Initial rpm release.
109