1%define name    libdvdcss
2%define version 1.4.3
3%define release 1
4
5%define major   2
6%define libname %{name}%{major}
7
8%define buildfor_rh9 %([[ -e /etc/mandrake-release ]] && echo 0 || echo 1)
9
10%if %buildfor_rh9
11# some mdk macros that do not exist in rh
12%define configure2_5x %configure
13%define make %__make
14%define makeinstall_std %makeinstall
15# adjust define for Red Hat.
16%endif
17
18
19Name:           %{name}
20Version:        %{version}
21Release:        %{release}%{?dist}
22Summary:        Library for accessing DVDs like block devices with transparent decryption
23Source:         %{name}-%{version}.tar.bz2
24License:        GPL
25Group:          System/Libraries
26URL:            https://www.videolan.org/developers/libdvdcss.html
27Packager:       Yves Duret <yves@zarb.org>
28BuildRoot:      %_tmppath/%name-%version-%release-root
29Conflicts:      libdvdcss0.0.1, libdvdcss0.0.2
30
31%description
32libdvdcss is a simple library designed for accessing DVDs like a block device
33without having to bother about the decryption. The important features are:
34 * Portability: Currently supported platforms are GNU/Linux, FreeBSD, NetBSD,
35   OpenBSD, Haiku, Mac OS X, Solaris, QNX, OS/2, and Windows 2000 or later.
36 * Adaptability: Unlike most similar projects, libdvdcss does not require the
37   region of your drive to be set and will try its best to read from the disc
38   even in the case of a region mismatch.
39 * Simplicity: A DVD player can be built around the libdvdcss API using no
40   more than 4 or 5 library calls.
41
42%package -n %{libname}
43Summary:        Library for accessing DVDs like block devices with transparent decryption
44Group:          System/Libraries
45Provides:       %name = %version-%release
46
47%description -n %{libname}
48libdvdcss is a simple library designed for accessing DVDs like a block device
49without having to bother about the decryption. The important features are:
50 * Portability: Currently supported platforms are GNU/Linux, FreeBSD, NetBSD,
51   OpenBSD, Haiku, Mac OS X, Solaris, QNX, OS/2, and Windows 2000 or later.
52 * Adaptability: Unlike most similar projects, libdvdcss does not require the
53   region of your drive to be set and will try its best to read from the disc
54   even in the case of a region mismatch.
55 * Simplicity: A DVD player can be built around the libdvdcss API using no
56   more than 4 or 5 library calls.
57
58%package -n %{libname}-devel
59Summary:        Development tools for programs which will use the %{name} library
60Group:          Development/C
61Requires:       %{libname} = %version-%release
62Provides:       %{name}-devel = %version-%release
63
64%description -n %{libname}-devel
65The %{name}-devel package includes the header files and static libraries
66necessary for developing programs which will manipulate DVDs files using
67the %{name} library.
68
69If you are going to develop programs which will manipulate DVDs, you
70should install %{name}-devel.  You will also need to have the %{name}
71package installed.
72
73%prep
74%setup -q
75
76%build
77%configure2_5x
78%make
79
80%install
81%makeinstall_std
82
83%clean
84[ %buildroot != "/" ] && rm -Rf %buildroot
85
86%post -n %{libname} -p /sbin/ldconfig
87
88%postun -n %{libname} -p /sbin/ldconfig
89
90%files -n %{libname}
91%defattr(-,root,root)
92%doc AUTHORS COPYING NEWS
93%{_docdir}/libdvdcss
94%{_libdir}/*.so.*
95
96%files -n %{libname}-devel
97%defattr(-,root,root)
98%doc ChangeLog COPYING
99%{_libdir}/*.a
100%{_libdir}/*.so
101%{_libdir}/*.la
102%{_libdir}/pkgconfig/*
103%{_includedir}/*
104
105%changelog
106* Mon Jul 11 2005 Sam Hocevar <sam@zoy.org> 1.2.9-1
107- new upstream release
108
109* Tue Jul 29 2003 Sam Hocevar <sam@zoy.org> 1.2.8-1
110- new upstream release
111
112* Fri Jun 13 2003 Sam Hocevar <sam@zoy.org> 1.2.7-1
113- new upstream release
114- key cache activated by default
115
116* Mon Mar 10 2003 Alexis de Lattre <alexis@videolan.org> 1.2.6-1
117- new upstream release
118- small bug fixes
119
120* Tue Jan 28 2003 Sam Hocevar <sam@zoy.org> 1.2.5-1
121- new upstream release
122- improved robustness in case of read errors
123- key cache support
124- added more macros to fix Red Hat build
125
126* Mon Nov 18 2002 Alexis de Lattre <alexis@videolan.org> 1.2.4-2
127- Changes in .spec file for Red Hat and RPM 4.1
128
129* Thu Nov 14 2002 Alexis de Lattre <alexis@videolan.org> 1.2.4-1
130- new upstream release
131- fixes for Win32
132
133* Sun Oct 13 2002 Sam Hocevar <sam@zoy.org> 1.2.3-1
134- new upstream release
135- fix for drives not allowing to read their disc key
136
137* Sat Aug 10 2002 Sam Hocevar <sam@zoy.org> 1.2.2-1
138- new upstream release
139- even more fixes for the disc/drive region mismatch problem
140
141* Sun Jun 02 2002 Sam Hocevar <sam@zoy.org> 1.2.1-1
142- new upstream release
143- fix for a crash on disc/drive region mismatch
144
145* Mon May 20 2002 Sam Hocevar <sam@zoy.org> 1.2.0-1
146- new upstream release
147- weird libxalf dependency is gone
148
149* Sun Apr 07 2002 Yves Duret <yduret@mandrakesoft.com> 1.1.1-2plf
150- major version is 2 (aka guillaume sux).
151- spec clean up: do not rm in %%prep, %%buildroot, %%makeinstall_std, %%provides %%version-%%release
152- added doc in devel
153- sync with the CVS one (%%description,%%files, conflicts).
154- fix URL
155
156* Sat Apr 06 2002 Guillaume Rousse <rousse@ccr.jussieu.fr> 1.1.1-1plf
157- 1.1.1
158
159* Wed Jan 30 2002 Guillaume Rousse <rousse@ccr.jussieu.fr> 1.0.0-3plf
160- new plf extension
161
162* Wed Dec 05 2001 Guillaume Rousse <g.rousse@linux-mandrake.com> 1.0.0-3mdk
163- removed conflict
164
165* Tue Dec 04 2001 Guillaume Rousse <g.rousse@linux-mandrake.com> 1.0.0-2mdk
166- contributed to PLF by Yves Duret <yduret@mandrakesoft.com>
167- Conflicts: libdvdcss-ogle
168- more doc files
169- no doc file for devel package
170
171* Fri Nov 30 2001 Yves Duret <yduret@mandrakesoft.com> 1.0.0-1mdk
172- version 1.0.0
173
174* Thu Aug 23 2001 Yves Duret <yduret@mandrakesoft.com> 0.0.3-1mdk
175- version 0.0.3
176
177* Mon Aug 13 2001 Yves Duret <yduret@mandrakesoft.com> 0.0.2-1mdk
178- version 0.0.2
179
180* Tue Jun 19 2001 Yves Duret <yduret@mandrakesoft.com> 0.0.1-1mdk
181- first release and first mdk release
182