1#================================================================
2# RPM Specification for QDBM
3#================================================================
4
5
6
7%define name qdbm
8%define version 1.8.77
9%define release 1
10%define libver 14
11%define librev 13
12%define disturl http://qdbm.sourceforge.net/
13%define homeurl http://qdbm.sourceforge.net/
14
15Summary: Quick Database Manager
16Name: %{name}
17Version: %{version}
18Release: %{release}
19Source: %{disturl}%{name}-%{version}.tar.gz
20Copyright: LGPL
21Group: Development/Libraries
22Packager: Mikio Hirabayashi <mikio@users.sourceforge.net>
23Distribution: Private
24Vendor: Private
25Url: %{homeurl}
26Requires: zlib
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28
29%description
30QDBM is an embeded database library compatible with GDBM and NDBM.
31It features hash database and B+ tree database and is developed referring
32to GDBM for the purpose of the following three points: higher processing
33speed, smaller size of a database file, and simpler API.
34This package includes APIs for C, C++, and Java.  CGI scripts are also
35contained.  APIs for Perl and Ruby should be installed with a source package.
36
37%package devel
38Summary: Headers, libraries, utilities and documentation for QDBM
39Group: Development/Libraries
40Requires: %{name} = %{version}
41
42%description devel
43This package contains header files and libraries needed to develop programs
44using the QDBM library.  Some utility commands are also provided.
45
46%package plus
47Summary: C++ libraries for QDBM
48Group: Development/Libraries
49Requires: %{name} = %{version}
50
51%description plus
52This package contains libraries needed to develop and run programs using the
53QDBM C++ bindings.
54
55%package java
56Summary: Java libraries for QDBM
57Group: Development/Libraries
58Requires: %{name} = %{version}
59
60%description java
61This package contains libraries needed to develop and run programs using the
62QDBM Java bindings.
63
64%package cgi
65Summary: CGI scripts with QDBM
66Group: Development/Libraries
67Requires: %{name} = %{version}
68
69%description cgi
70This package contains CGI scripts with QDBM, for administration of databases,
71file uploading, and full-text search.
72
73%prep
74rm -rf $RPM_BUILD_ROOT
75
76%setup -q
77
78%build
79( cd . ; %{configure} --prefix=%{_usr} --mandir=%{_mandir} \
80  --enable-stable --enable-zlib --enable-iconv --enable-pthread ; make )
81( cd plus ; %{configure} --prefix=%{_usr} --mandir=%{_mandir} ; make )
82( cd java ; %{configure} --prefix=%{_usr} --mandir=%{_mandir} ; make )
83( cd cgi ; %{configure} --prefix=%{_usr} --mandir=%{_mandir} ; make )
84
85%install
86rm -rf $RPM_BUILD_ROOT
87( cd . ; make DESTDIR=$RPM_BUILD_ROOT install-strip )
88( cd plus ; make DESTDIR=$RPM_BUILD_ROOT install-strip )
89( cd java ; make DESTDIR=$RPM_BUILD_ROOT install )
90( cd cgi ; make DESTDIR=$RPM_BUILD_ROOT install-strip )
91( mkdir -p $RPM_BUILD_ROOT%{_datadir}/doc/qdbm && \
92  cd $RPM_BUILD_ROOT%{_usr}/share/qdbm && \
93  cp -Rf spex-ja.html spex.html COPYING ChangeLog NEWS THANKS \
94    plus/xspex.html plus/xspex-ja.html plus/xapidoc \
95    java/jspex.html java/jspex-ja.html java/japidoc \
96    cgi/cgispex-ja.html cgi/cgispex.html $RPM_BUILD_ROOT%{_datadir}/doc/qdbm )
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%files
102%defattr(-,root,root)
103%{_libdir}/libqdbm.so.%{libver}.%{librev}.0
104%{_libdir}/libqdbm.so.%{libver}
105%{_libdir}/libqdbm.so
106
107%files devel
108%defattr(-,root,root)
109%{_includedir}/depot.h
110%{_includedir}/curia.h
111%{_includedir}/relic.h
112%{_includedir}/hovel.h
113%{_includedir}/cabin.h
114%{_includedir}/villa.h
115%{_includedir}/vista.h
116%{_includedir}/odeum.h
117%{_libdir}/libqdbm.a
118%{_bindir}/dpmgr
119%{_bindir}/dptest
120%{_bindir}/dptsv
121%{_bindir}/crmgr
122%{_bindir}/crtest
123%{_bindir}/crtsv
124%{_bindir}/rlmgr
125%{_bindir}/rltest
126%{_bindir}/hvmgr
127%{_bindir}/hvtest
128%{_bindir}/cbtest
129%{_bindir}/cbcodec
130%{_bindir}/vlmgr
131%{_bindir}/vltest
132%{_bindir}/vltsv
133%{_bindir}/odmgr
134%{_bindir}/odtest
135%{_bindir}/odidx
136%{_bindir}/qmttest
137%{_mandir}/man1/dpmgr.1.gz
138%{_mandir}/man1/dptest.1.gz
139%{_mandir}/man1/dptsv.1.gz
140%{_mandir}/man1/crmgr.1.gz
141%{_mandir}/man1/crtest.1.gz
142%{_mandir}/man1/crtsv.1.gz
143%{_mandir}/man1/rlmgr.1.gz
144%{_mandir}/man1/rltest.1.gz
145%{_mandir}/man1/hvmgr.1.gz
146%{_mandir}/man1/hvtest.1.gz
147%{_mandir}/man1/cbtest.1.gz
148%{_mandir}/man1/cbcodec.1.gz
149%{_mandir}/man1/vlmgr.1.gz
150%{_mandir}/man1/vltest.1.gz
151%{_mandir}/man1/vltsv.1.gz
152%{_mandir}/man1/odmgr.1.gz
153%{_mandir}/man1/odtest.1.gz
154%{_mandir}/man1/odidx.1.gz
155%{_mandir}/man1/qmttest.1.gz
156%{_mandir}/man3/qdbm.3.gz
157%{_mandir}/man3/depot.3.gz
158%{_mandir}/man3/dpopen.3.gz
159%{_mandir}/man3/curia.3.gz
160%{_mandir}/man3/cropen.3.gz
161%{_mandir}/man3/relic.3.gz
162%{_mandir}/man3/hovel.3.gz
163%{_mandir}/man3/cabin.3.gz
164%{_mandir}/man3/villa.3.gz
165%{_mandir}/man3/vlopen.3.gz
166%{_mandir}/man3/vista.3.gz
167%{_mandir}/man3/odeum.3.gz
168%{_mandir}/man3/odopen.3.gz
169%{_datadir}/doc/qdbm/spex.html
170%{_datadir}/doc/qdbm/spex-ja.html
171%{_datadir}/doc/qdbm/COPYING
172%{_datadir}/doc/qdbm/ChangeLog
173%{_datadir}/doc/qdbm/NEWS
174%{_datadir}/doc/qdbm/THANKS
175%{_libdir}/pkgconfig/qdbm.pc
176
177%files plus
178%defattr(-,root,root)
179%{_includedir}/xqdbm.h
180%{_includedir}/xadbm.h
181%{_includedir}/xdepot.h
182%{_includedir}/xcuria.h
183%{_includedir}/xvilla.h
184%{_libdir}/libxqdbm.a
185%{_libdir}/libxqdbm.so.3.0.0
186%{_libdir}/libxqdbm.so.3
187%{_libdir}/libxqdbm.so
188%{_bindir}/xdptest
189%{_bindir}/xcrtest
190%{_bindir}/xvltest
191%{_datadir}/doc/qdbm/xspex.html
192%{_datadir}/doc/qdbm/xspex-ja.html
193%{_datadir}/doc/qdbm/xapidoc/
194
195%files java
196%defattr(-,root,root)
197%{_libdir}/qdbm.jar
198%{_libdir}/libjqdbm.so.1.0.0
199%{_libdir}/libjqdbm.so.1
200%{_libdir}/libjqdbm.so
201%{_datadir}/doc/qdbm/jspex.html
202%{_datadir}/doc/qdbm/jspex-ja.html
203%{_datadir}/doc/qdbm/japidoc/
204
205%files cgi
206%defattr(-,root,root)
207%{_libexecdir}/qadm.cgi
208%{_libexecdir}/qupl.cgi
209%{_libexecdir}/qfts.cgi
210%{_datadir}/qdbm/cgi/qadm.conf
211%{_datadir}/qdbm/cgi/qupl.conf
212%{_datadir}/qdbm/cgi/qfts.conf
213%{_datadir}/doc/qdbm/cgispex.html
214%{_datadir}/doc/qdbm/cgispex-ja.html
215
216
217
218# END OF FILE
219