1{ pkgs ? import ./nix {} }:
2with pkgs;
3
4buildGoModule rec {
5  name = "direnv-${version}";
6  version = lib.fileContents ./version.txt;
7  subPackages = ["."];
8
9  vendorSha256 = "084x7d7sshcsyim76d6pl6127nlqacgwwnm965srl9y5w5nqzba6";
10
11  src = lib.cleanSource ./.;
12
13  # we have no bash at the moment for windows
14  makeFlags = stdenv.lib.optional (!stdenv.hostPlatform.isWindows) [
15    "BASH_PATH=${bash}/bin/bash"
16  ];
17
18  installPhase = ''
19    make install PREFIX=$out
20  '';
21
22  meta = with stdenv.lib; {
23    description = "A shell extension that manages your environment";
24    homepage = https://direnv.net;
25    license = licenses.mit;
26    maintainers = with maintainers; [ zimbatm ];
27  };
28}
29