1# $Id: tk.spec,v 1.15.2.3 2003/10/03 16:32:39 dgp Exp $
2# This file is the basis for a binary Tk Linux RPM.
3
4%define version 8.4.5
5%define directory /usr/local
6
7Summary: Tk graphical toolkit for the Tcl scripting language.
8Name: tk
9Version: %{version}
10Release: 1
11Copyright: BSD
12Group: Development/Languages
13Source: http://prdownloads.sourceforge.net/tcl/tk%{version}-src.tar.gz
14URL: http://www.tcl.tk/
15Packager: Carina
16Buildroot: /var/tmp/%{name}%{version}
17Requires: XFree86-libs >= 3.3.3, XFree86-devel >= 3.3.3, tcl = 8.4.5
18
19%description
20The Tcl (Tool Command Language) provides a powerful platform for
21creating integration applications that tie together diverse
22applications, protocols, devices, and frameworks.  When paired with
23the Tk toolkit, Tcl provides the fastest and most powerful way to
24create GUI applications that run on PCs, Unix, and the Macintosh.  Tcl
25can also be used for a variety of web-related tasks and for creating
26powerful command languages for applications.
27
28%prep
29
30%build
31./configure --prefix %{directory} --exec-prefix %{directory}
32make CFLAGS=$RPM_OPT_FLAGS
33
34%install
35rm -rf $RPM_BUILD_ROOT
36make INSTALL_ROOT=$RPM_BUILD_ROOT install
37
38%clean
39rm -rf $RPM_BUILD_ROOT
40
41# to create the tcl files list, comment out tk in the install section above,
42# then run "rpm -bi" then do a find from the build root directory,
43# and remove the files in specific directories which suffice by themselves,
44# then to create the files list for tk, uncomment tk, comment out tcl,
45# then rm -rf $RPM_BUILD_ROOT then rpm --short-circuit -bi then redo a find,
46# and remove the files in specific directories which suffice by themselves.
47%files -n tk
48%defattr(-,root,root)
49%{directory}/lib
50%{directory}/bin
51%{directory}/include
52%{directory}/man
53