1# Copyright 1999-2008 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-@version@.ebuild,v 1.10 2008/05/17 14:11:56 truedfx Exp $
4
5inherit eutils toolchain-funcs multilib
6
7DESCRIPTION="A GTK+ language binding for the librep Lisp environment"
8HOMEPAGE="http://rep-gtk.sourceforge.net/"
9SRC_URI="mirror://sourceforge/rep-gtk/${P}.tar.bz2"
10
11LICENSE="GPL-2"
12SLOT="gtk-2.0"
13KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
14
15RDEPEND=">=dev-libs/librep-@REP_MIN_VER@
16	x11-libs/gtk+-@GTK_MIN_VER@"
17DEPEND="${RDEPEND}
18	dev-util/pkgconfig"
19
20src_compile() {
21	econf || die "configure failed"
22	emake || die "make failed"
23}
24
25src_install() {
26	make DESTDIR="${D}" install || die "make install failed"
27
28	dodoc AUTHORS BUGS ChangeLog HACKING NEWS README* TODO
29}
30