1#!/usr/bin/make -f
2# Sample debian/rules that uses debhelper.
3# GNU copyright 1997 to 1999 by Joey Hess.
4
5# Uncomment this to turn on verbose mode.
6#export DH_VERBOSE=1
7
8# This is the debhelper compatibility version to use.
9export DH_COMPAT=3
10
11# These are used for cross-compiling and for saving the configure script
12# from having to guess our platform (since we know it already)
13DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
14DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
15
16
17ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
18	CFLAGS += -g
19endif
20ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
21	INSTALL_PROGRAM += -s
22endif
23
24config.status: configure
25	dh_testdir
26	# Add here commands to configure the package.
27	./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
28
29
30build: build-stamp
31
32build-stamp:  config.status
33	dh_testdir
34
35	# Add here commands to compile the package.
36	$(MAKE)
37	#/usr/bin/docbook-to-man debian/fireflies.sgml > fireflies.1
38
39	touch build-stamp
40
41clean:
42	dh_testdir
43	dh_testroot
44	rm -f build-stamp
45
46	# Add here commands to clean up after the build process.
47	-$(MAKE) distclean
48	-test -r /usr/share/misc/config.sub && \
49	  cp -f /usr/share/misc/config.sub config.sub
50	-test -r /usr/share/misc/config.guess && \
51	  cp -f /usr/share/misc/config.guess config.guess
52
53
54	dh_clean
55
56install: build
57	dh_testdir
58	dh_testroot
59	dh_clean -k
60	dh_installdirs
61
62	# Add here commands to install the package into debian/fireflies.
63	$(MAKE) install DESTDIR=$(CURDIR)/debian/fireflies/
64
65# Build architecture-independent files here.
66binary-indep: build install
67# We have nothing to do by default.
68
69# Build architecture-dependent files here.
70binary-arch: build install
71	dh_testdir
72	dh_testroot
73#	dh_installdebconf
74	dh_installdocs
75	dh_installexamples
76	dh_installmenu
77#	dh_installlogrotate
78#	dh_installemacsen
79#	dh_installpam
80#	dh_installmime
81#	dh_installinit
82	dh_installcron
83	dh_installman
84	dh_installinfo
85#	dh_undocumented
86	dh_installchangelogs ChangeLog
87	dh_link
88	dh_strip
89	dh_compress
90	dh_fixperms
91#	dh_makeshlibs
92	dh_installdeb
93#	dh_perl
94	dh_shlibdeps
95	dh_gencontrol
96	dh_md5sums
97	dh_builddeb
98
99binary: binary-indep binary-arch
100.PHONY: build clean binary-indep binary-arch binary install
101